# CVE-2021-21619: XSS vulnerability in Jenkins Claim Plugin

> Attackers can inject malicious scripts via user display names in the Jenkins Claim Plugin, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-48hr-jg4p-w4p4

## What is CVE-2021-21619?

CVE-2021-21619 is a medium-severity cross-site scripting vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Claim Plugin 2.18.1 and earlier does not escape the user display name, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers who are able to control the display names of Jenkins users, either via the security realm, or directly inside Jenkins.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21619?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:claim. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:claim` | Maven | All versions | 2.18.2 |
| `org.jenkins-ci.plugins:claim` | Maven | All versions | 2.18.2 |

Products: Jenkins Claim.

## How do I fix CVE-2021-21619?

Upgrade org.jenkins-ci.plugins:claim to 2.18.2 or later.

## Is CVE-2021-21619 being exploited?

There is no known exploitation of CVE-2021-21619 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Claim Plugin

- [CVE-2021-21620](https://insights.sbomify.com/CVE-2021-21620/): Cross-Site Request Forgery in the Jenkins Claim plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21619 and fix it if it is affected.

What it is: CVE-2021-21619 is a medium-severity cross-site scripting vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21619 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2
- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21619/ (Markdown: https://insights.sbomify.com/CVE-2021-21619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21619
- OSV: https://osv.dev/vulnerability/CVE-2021-21619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21619/
Summaries are generated and may contain mistakes; the official description above is the record.
