{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:claim. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21620 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:claim to 2.18.2 or later.","what":"CVE-2021-21620 is a medium-severity vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21620 and fix it if it is affected.\n\nWhat it is: CVE-2021-21620 is a medium-severity vulnerability in Jenkins Claim Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21620 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2\n- org.jenkins-ci.plugins:claim (Maven): affected all versions; fixed in 2.18.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21620/ (Markdown: https://insights.sbomify.com/CVE-2021-21620/index.md)","id":"CVE-2021-21620","markdown":"https://insights.sbomify.com/CVE-2021-21620/index.md","name":"CVE-2021-21620","record":{"aliases":["GHSA-4ffq-6g62-j4v4"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Claim Plugin","requires_auth":"none","summary":"Attackers can force users to change claims via CSRF, requiring Jenkins administrators to update the Claim Plugin.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"claim","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Claim Plugin 2.18.1 and earlier allows attackers to change claims.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Request Forgery in the Jenkins Claim plugin","id":"CVE-2021-21620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Support bundles can include user session IDs in Jenkins Support Core Plugin","id":"CVE-2021-21621"},"packages":[{"ecosystem":"Maven","fixed":["2.18.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:claim","purl":null,"source":"GHSA-4ffq-6g62-j4v4"},{"ecosystem":"Maven","fixed":["2.18.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:claim","purl":"pkg:maven/org.jenkins-ci.plugins/claim","source":"GHSA-4ffq-6g62-j4v4"}],"prev":{"headline":"XSS vulnerability in Jenkins Claim Plugin","id":"CVE-2021-21619"},"products":["Jenkins Claim Plugin"],"published":"2021-02-24","related":[{"cvss_score":5.4,"headline":"XSS vulnerability in Jenkins Claim Plugin","id":"CVE-2021-21619","kev_date_added":null,"published":"2021-02-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can force users to change claims via CSRF, requiring Jenkins administrators to update the Claim Plugin.","url":"https://insights.sbomify.com/CVE-2021-21620/"}