# CVE-2021-21621: Support bundles can include user session IDs in Jenkins Support Core Plugin

> The Jenkins Support Core Plugin may leak session IDs in support bundles, potentially allowing attackers to hijack user accounts.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Feb 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-92pg-8g57-hqpx

## What is CVE-2021-21621?

CVE-2021-21621 is a medium-severity vulnerability in Jenkins Support Core Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Support Core Plugin 2.72 and earlier provides the serialized user authentication as part of the "About user (basic authentication details only)" information, which can include the session ID of the user creating the support bundle in some configurations.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-21621?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:support-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:support-core` | Maven | All versions | 2.72.1 |
| `org.jenkins-ci.plugins:support-core` | Maven | All versions | 2.72.1 |

Products: Jenkins Support Core.

## How do I fix CVE-2021-21621?

Upgrade org.jenkins-ci.plugins:support-core to 2.72.1 or later.

## Is CVE-2021-21621 being exploited?

There is no known exploitation of CVE-2021-21621 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Support Core Plugin

- [CVE-2022-45383](https://insights.sbomify.com/CVE-2022-45383/): Incorrect permission checks in Jenkins Support Core Plugin (medium 6.5)
- [CVE-2022-25187](https://insights.sbomify.com/CVE-2022-25187/): Jenkins Support Core Plugin stores sensitive data in plain text (medium 6.5)
- [CVE-2019-16539](https://insights.sbomify.com/CVE-2019-16539/): Missing permission check in Jenkins Support Core Plugin (medium 6.5)
- [CVE-2019-16540](https://insights.sbomify.com/CVE-2019-16540/): Jenkins Support Core Plugin allowed users with Overall/Read permission to delete arbitrary files (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21621 and fix it if it is affected.

What it is: CVE-2021-21621 is a medium-severity vulnerability in Jenkins Support Core Plugin, published on 24 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21621 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:support-core (Maven): affected all versions; fixed in 2.72.1
- org.jenkins-ci.plugins:support-core (Maven): affected all versions; fixed in 2.72.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21621/ (Markdown: https://insights.sbomify.com/CVE-2021-21621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21621
- OSV: https://osv.dev/vulnerability/CVE-2021-21621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21621/
Summaries are generated and may contain mistakes; the official description above is the record.
