{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:artifact-repository-parameter. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21622 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:artifact-repository-parameter to 1.0.1 or later.","what":"CVE-2021-21622 is a medium-severity cross-site scripting vulnerability in Jenkins Artifact Repository Parameter Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21622 and fix it if it is affected.\n\nWhat it is: CVE-2021-21622 is a medium-severity cross-site scripting vulnerability in Jenkins Artifact Repository Parameter Plugin, published on 24 Feb 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21622 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:artifact-repository-parameter (Maven): affected all versions; fixed in 1.0.1\n- io.jenkins.plugins:artifact-repository-parameter (Maven): affected all versions; fixed in 1.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21622/ (Markdown: https://insights.sbomify.com/CVE-2021-21622/index.md)","id":"CVE-2021-21622","markdown":"https://insights.sbomify.com/CVE-2021-21622/index.md","name":"CVE-2021-21622","record":{"aliases":["GHSA-gc87-qwmv-7x9x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Artifact Repository Parameter Plugin allows attackers with Job/Configure permission to execute scripts in other users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"artifact_repository_parameter","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Artifact Repository Parameter Plugin 1.0.0 and earlier does not escape parameter names and descriptions, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Artifact Repository Parameter Plugin","id":"CVE-2021-21622","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Incorrect permission checks in Jenkins Matrix Authorization Strategy Plugin may allow accessing some items","id":"CVE-2021-21623"},"packages":[{"ecosystem":"Maven","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:artifact-repository-parameter","purl":null,"source":"GHSA-gc87-qwmv-7x9x"},{"ecosystem":"Maven","fixed":["1.0.1"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:artifact-repository-parameter","purl":"pkg:maven/io.jenkins.plugins/artifact-repository-parameter","source":"GHSA-gc87-qwmv-7x9x"}],"prev":{"headline":"Support bundles can include user session IDs in Jenkins Support Core Plugin","id":"CVE-2021-21621"},"products":["Jenkins Artifact Repository Parameter Plugin"],"published":"2021-02-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Artifact Repository Parameter Plugin allows attackers with Job/Configure permission to execute scripts in other users' browsers.","url":"https://insights.sbomify.com/CVE-2021-21622/"}