{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21626 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:warnings-ng to 8.5.0 or later.","what":"CVE-2021-21626 is a medium-severity missing authorization vulnerability in Jenkins Warnings Next Generation Plugin, published on 18 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21626 and fix it if it is affected.\n\nWhat it is: CVE-2021-21626 is a medium-severity missing authorization vulnerability in Jenkins Warnings Next Generation Plugin, published on 18 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21626 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 8.5.0\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 8.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21626/ (Markdown: https://insights.sbomify.com/CVE-2021-21626/index.md)","id":"CVE-2021-21626","markdown":"https://insights.sbomify.com/CVE-2021-21626/index.md","name":"CVE-2021-21626","record":{"aliases":["GHSA-7j3x-xm4j-jfj7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can bypass authorization checks to verify if specific file patterns exist in the workspace.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings_next_generation","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents","id":"CVE-2021-21626","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Jenkins Libvirt Agents Plugin","id":"CVE-2021-21627"},"packages":[{"ecosystem":"Maven","fixed":["8.5.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-7j3x-xm4j-jfj7"},{"ecosystem":"Maven","fixed":["8.5.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-7j3x-xm4j-jfj7"}],"prev":{"headline":"Missing permission checks in Jenkins CloudBees AWS Credentials Plugin allows enumerating credentials IDs","id":"CVE-2021-21625"},"products":["Jenkins Warnings Next Generation Plugin"],"published":"2021-03-18","related":[{"cvss_score":8.8,"headline":"Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability","id":"CVE-2019-1003008","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":8.1,"headline":"Path Traversal in Jenkins Warnings Next Generation Plugin","id":"CVE-2022-23107","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":6.1,"headline":"XSS vulnerability in Jenkins Warnings Next Generation Plugin","id":"CVE-2019-1003023","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":5.4,"headline":"Jenkins Warnings NG Plugin Cross-site scripting vulnerability","id":"CVE-2019-10325","kev_date_added":null,"published":"2019-05-31"},{"cvss_score":4.3,"headline":"Jenkins Warnings NG Plugin cross-site request forgery vulnerability","id":"CVE-2019-10326","kev_date_added":null,"published":"2019-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can bypass authorization checks to verify if specific file patterns exist in the workspace.","url":"https://insights.sbomify.com/CVE-2021-21626/"}