# CVE-2021-21626: Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents

> Attackers with read permissions can bypass authorization checks to verify if specific file patterns exist in the workspace.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-7j3x-xm4j-jfj7

## What is CVE-2021-21626?

CVE-2021-21626 is a medium-severity missing authorization vulnerability in Jenkins Warnings Next Generation Plugin, published on 18 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Warnings Next Generation Plugin 8.4.4 and earlier does not perform a permission check in methods implementing form validation, allowing attackers with Item/Read permission but without Item/Workspace or Item/Configure permission to check whether attacker-specified file patterns match workspace contents.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2021-21626?

2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 8.5.0 |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 8.5.0 |

Products: Jenkins Warnings Next Generation.

## How do I fix CVE-2021-21626?

Upgrade io.jenkins.plugins:warnings-ng to 8.5.0 or later.

## Is CVE-2021-21626 being exploited?

There is no known exploitation of CVE-2021-21626 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings Next Generation Plugin

- [CVE-2019-1003008](https://insights.sbomify.com/CVE-2019-1003008/): Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2022-23107](https://insights.sbomify.com/CVE-2022-23107/): Path Traversal in Jenkins Warnings Next Generation Plugin (high 8.1)
- [CVE-2019-1003023](https://insights.sbomify.com/CVE-2019-1003023/): XSS vulnerability in Jenkins Warnings Next Generation Plugin (medium 6.1)
- [CVE-2019-10325](https://insights.sbomify.com/CVE-2019-10325/): Jenkins Warnings NG Plugin Cross-site scripting vulnerability (medium 5.4)
- [CVE-2019-10326](https://insights.sbomify.com/CVE-2019-10326/): Jenkins Warnings NG Plugin cross-site request forgery vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21626 and fix it if it is affected.

What it is: CVE-2021-21626 is a medium-severity missing authorization vulnerability in Jenkins Warnings Next Generation Plugin, published on 18 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21626 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 8.5.0
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 8.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21626/ (Markdown: https://insights.sbomify.com/CVE-2021-21626/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21626
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21626
- OSV: https://osv.dev/vulnerability/CVE-2021-21626

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21626/
Summaries are generated and may contain mistakes; the official description above is the record.
