{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:libvirt-slave. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21627 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:libvirt-slave to 1.9.1 or later.","what":"CVE-2021-21627 is a high-severity vulnerability in Jenkins Libvirt Agents Plugin, published on 18 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21627 and fix it if it is affected.\n\nWhat it is: CVE-2021-21627 is a high-severity vulnerability in Jenkins Libvirt Agents Plugin, published on 18 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21627 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.9.1\n- org.jenkins-ci.plugins:libvirt-slave (Maven): affected all versions; fixed in 1.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21627/ (Markdown: https://insights.sbomify.com/CVE-2021-21627/index.md)","id":"CVE-2021-21627","markdown":"https://insights.sbomify.com/CVE-2021-21627/index.md","name":"CVE-2021-21627","record":{"aliases":["GHSA-mm5c-7mpr-99fm"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Libvirt Agents Plugin","requires_auth":"none","summary":"Attackers can exploit CSRF to stop hypervisor domains in Jenkins Libvirt Agents Plugin, causing service disruption.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"libvirt_agents","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A cross-site request forgery (CSRF) vulnerability in Jenkins Libvirt Agents Plugin 1.9.0 and earlier allows attackers to stop hypervisor domains.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in Jenkins Libvirt Agents Plugin","id":"CVE-2021-21627","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins Build With Parameters Plugin","id":"CVE-2021-21628"},"packages":[{"ecosystem":"Maven","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:libvirt-slave","purl":null,"source":"GHSA-mm5c-7mpr-99fm"},{"ecosystem":"Maven","fixed":["1.9.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:libvirt-slave","purl":"pkg:maven/org.jenkins-ci.plugins/libvirt-slave","source":"GHSA-mm5c-7mpr-99fm"}],"prev":{"headline":"Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents","id":"CVE-2021-21626"},"products":["Jenkins Libvirt Agents Plugin"],"published":"2021-03-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers can exploit CSRF to stop hypervisor domains in Jenkins Libvirt Agents Plugin, causing service disruption.","url":"https://insights.sbomify.com/CVE-2021-21627/"}