# CVE-2021-21633: CSRF vulnerability and in Jenkins OWASP Dependency-Track Plugin allow capturing credentials

> Attackers can exploit CSRF to force Jenkins to connect to malicious URLs, potentially capturing stored credentials.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-v7xh-h48c-xw5f

## What is CVE-2021-21633?

CVE-2021-21633 is a high-severity vulnerability in Jenkins OWASP Dependency-Track Plugin, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins OWASP Dependency-Track Plugin 3.1.0 and earlier allows attackers to connect to an attacker-specified URL, capturing credentials stored in Jenkins.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-21633?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:dependency-track. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:dependency-track` | Maven | All versions | 3.1.1 |
| `org.jenkins-ci.plugins:dependency-track` | Maven | All versions | 3.1.1 |

Products: Jenkins Owasp Dependency-Track.

## How do I fix CVE-2021-21633?

Upgrade org.jenkins-ci.plugins:dependency-track to 3.1.1 or later.

## Is CVE-2021-21633 being exploited?

There is no known exploitation of CVE-2021-21633 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OWASP Dependency-Track Plugin

- [CVE-2021-21632](https://insights.sbomify.com/CVE-2021-21632/): Missing permission checks in Jenkins OWASP Dependency-Track Plugin allow capturing credentials (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21633 and fix it if it is affected.

What it is: CVE-2021-21633 is a high-severity vulnerability in Jenkins OWASP Dependency-Track Plugin, published on 30 Mar 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21633 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:dependency-track (Maven): affected all versions; fixed in 3.1.1
- org.jenkins-ci.plugins:dependency-track (Maven): affected all versions; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21633/ (Markdown: https://insights.sbomify.com/CVE-2021-21633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21633
- OSV: https://osv.dev/vulnerability/CVE-2021-21633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21633/
Summaries are generated and may contain mistakes; the official description above is the record.
