# CVE-2021-21634: Passwords stored in plain text by Jenkins Jabber (XMPP) notifier and control Plugin

> Attackers with file system access can read unencrypted passwords stored in the Jenkins XMPP plugin configuration file.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-79r5-rhrw-7pvh

## What is CVE-2021-21634?

CVE-2021-21634 is a medium-severity vulnerability in Jenkins Jabber (XMPP) notifier and control Plugin, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Jabber (XMPP) notifier and control Plugin 1.41 and earlier stores passwords unencrypted in its global configuration file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2021-21634?

2 open source packages ship an affected version, including org.jvnet.hudson.plugins:jabber. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jvnet.hudson.plugins:jabber` | Maven | All versions | 1.42 |
| `org.jvnet.hudson.plugins:jabber` | Maven | All versions | 1.42 |

Products: Jenkins Jabber \(Xmpp\) Notifier and Control.

## How do I fix CVE-2021-21634?

Upgrade org.jvnet.hudson.plugins:jabber to 1.42 or later.

## Is CVE-2021-21634 being exploited?

There is no known exploitation of CVE-2021-21634 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21634 and fix it if it is affected.

What it is: CVE-2021-21634 is a medium-severity vulnerability in Jenkins Jabber (XMPP) notifier and control Plugin, published on 30 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21634 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jvnet.hudson.plugins:jabber (Maven): affected all versions; fixed in 1.42
- org.jvnet.hudson.plugins:jabber (Maven): affected all versions; fixed in 1.42

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21634/ (Markdown: https://insights.sbomify.com/CVE-2021-21634/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21634
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21634
- OSV: https://osv.dev/vulnerability/CVE-2021-21634

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21634/
Summaries are generated and may contain mistakes; the official description above is the record.
