# CVE-2021-21635: Stored XSS vulnerability in Jenkins REST List Parameter Plugin

> Stored XSS in Jenkins REST List Parameter Plugin allows attackers with Job/Configure permission to execute arbitrary scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-x3m6-vcp7-98mr

## What is CVE-2021-21635?

CVE-2021-21635 is a medium-severity cross-site scripting vulnerability in Jenkins REST List Parameter Plugin, published on 30 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins REST List Parameter Plugin 1.3.0 and earlier does not escape a parameter name reference in embedded JavaScript, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21635?

2 open source packages ship an affected version, including io.jenkins.plugins:rest-list-parameter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:rest-list-parameter` | Maven | All versions | 1.3.1 |
| `io.jenkins.plugins:rest-list-parameter` | Maven | All versions | 1.3.1 |

Products: Jenkins Rest List Parameter.

## How do I fix CVE-2021-21635?

Upgrade io.jenkins.plugins:rest-list-parameter to 1.3.1 or later.

## Is CVE-2021-21635 being exploited?

There is no known exploitation of CVE-2021-21635 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins REST List Parameter Plugin

- [CVE-2022-34196](https://insights.sbomify.com/CVE-2022-34196/): Cross-site Scripting in Jenkins REST List Parameter Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21635 and fix it if it is affected.

What it is: CVE-2021-21635 is a medium-severity cross-site scripting vulnerability in Jenkins REST List Parameter Plugin, published on 30 Mar 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21635 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:rest-list-parameter (Maven): affected all versions; fixed in 1.3.1
- io.jenkins.plugins:rest-list-parameter (Maven): affected all versions; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21635/ (Markdown: https://insights.sbomify.com/CVE-2021-21635/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21635
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21635
- OSV: https://osv.dev/vulnerability/CVE-2021-21635

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21635/
Summaries are generated and may contain mistakes; the official description above is the record.
