{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:config-file-provider. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21643 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:config-file-provider to 3.7.1 or later.","what":"CVE-2021-21643 is a medium-severity vulnerability in Jenkins Config File Provider Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21643 and fix it if it is affected.\n\nWhat it is: CVE-2021-21643 is a medium-severity vulnerability in Jenkins Config File Provider Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21643 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.7.1\n- org.jenkins-ci.plugins:config-file-provider (Maven): affected all versions; fixed in 3.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21643/ (Markdown: https://insights.sbomify.com/CVE-2021-21643/index.md)","id":"CVE-2021-21643","markdown":"https://insights.sbomify.com/CVE-2021-21643/index.md","name":"CVE-2021-21643","record":{"aliases":["GHSA-3m3f-2323-64m7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Config File Plugin","requires_auth":"low_privilege","summary":"Attackers with Job/Configure permissions can enumerate system-scoped credential IDs in Jenkins Config File Provider Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"config_file_provider","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[],"description":"Jenkins Config File Provider Plugin 3.7.0 and earlier does not correctly perform permission checks in several HTTP endpoints, allowing attackers with global Job/Configure permission to enumerate system-scoped credentials IDs of credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect permission checks in Jenkins Config File Provider Plugin allow enumerating credentials IDs","id":"CVE-2021-21643","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files","id":"CVE-2021-21644"},"packages":[{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:config-file-provider","purl":null,"source":"GHSA-3m3f-2323-64m7"},{"ecosystem":"Maven","fixed":["3.7.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:config-file-provider","purl":"pkg:maven/org.jenkins-ci.plugins/config-file-provider","source":"GHSA-3m3f-2323-64m7"}],"prev":{"headline":"XML External Entity Reference vulnerability in Jenkins Config File Provider Plugin","id":"CVE-2021-21642"},"products":["Jenkins Config File Provider Plugin"],"published":"2021-04-21","related":[{"cvss_score":8.1,"headline":"XML External Entity Reference vulnerability in Jenkins Config File Provider Plugin","id":"CVE-2021-21642","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":8.1,"headline":"CSRF vulnerability in Config File Provider Plugin","id":"CVE-2018-1000414","kev_date_added":null,"published":"2019-01-09"},{"cvss_score":7.5,"headline":"Jenkins Config File Provider Plugin improper credential masking vulnerability","id":"CVE-2023-40339","kev_date_added":null,"published":"2023-08-16"},{"cvss_score":6.5,"headline":"Improper Privilege Management in Jenkins Config File Provider Plugin","id":"CVE-2017-1000104","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":5.4,"headline":"CSRF vulnerability in Jenkins Config File Provider Plugin allows deleting configuration files","id":"CVE-2021-21644","kev_date_added":null,"published":"2021-04-21"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Config File Provider Plugin","id":"CVE-2018-1000413","kev_date_added":null,"published":"2019-01-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with Job/Configure permissions can enumerate system-scoped credential IDs in Jenkins Config File Provider Plugin.","url":"https://insights.sbomify.com/CVE-2021-21643/"}