{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:templating-engine. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21646 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:templating-engine to 2.2 or later.","what":"CVE-2021-21646 is a high-severity code injection vulnerability in Jenkins Templating Engine Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21646 and fix it if it is affected.\n\nWhat it is: CVE-2021-21646 is a high-severity code injection vulnerability in Jenkins Templating Engine Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21646 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:templating-engine (Maven): affected all versions; fixed in 2.2\n- org.jenkins-ci.plugins:templating-engine (Maven): affected all versions; fixed in 2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21646/ (Markdown: https://insights.sbomify.com/CVE-2021-21646/index.md)","id":"CVE-2021-21646","markdown":"https://insights.sbomify.com/CVE-2021-21646/index.md","name":"CVE-2021-21646","record":{"aliases":["GHSA-p6qc-37hq-wqr6"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Templating Engine Plugin","requires_auth":"low_privilege","summary":"Attackers with Job/Configure permission can execute arbitrary code on the Jenkins controller due to missing script security protections in the Templating Engine Plugin.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"templating_engine","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"Jenkins Templating Engine Plugin 2.1 and earlier does not protect its pipeline configurations using Script Security Plugin, allowing attackers with Job/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Remote code execution vulnerability in Jenkins Templating Engine Plugin","id":"CVE-2021-21646","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Missing permission check in Jenkins CloudBees CD Plugin allows scheduling builds","id":"CVE-2021-21647"},"packages":[{"ecosystem":"Maven","fixed":["2.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:templating-engine","purl":null,"source":"GHSA-p6qc-37hq-wqr6"},{"ecosystem":"Maven","fixed":["2.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:templating-engine","purl":"pkg:maven/org.jenkins-ci.plugins/templating-engine","source":"GHSA-p6qc-37hq-wqr6"}],"prev":{"headline":"Missing permission checks in Jenkins Config File Provider Plugin allow enumerating configuration file IDs","id":"CVE-2021-21645"},"products":["Jenkins Templating Engine Plugin"],"published":"2021-04-21","related":[{"cvss_score":8.8,"headline":"Jenkins Templating Engine Plugin Vulnerable to Arbitrary Code Execution","id":"CVE-2025-31722","kev_date_added":null,"published":"2025-04-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with Job/Configure permission can execute arbitrary code on the Jenkins controller due to missing script security protections in the Templating Engine Plugin.","url":"https://insights.sbomify.com/CVE-2021-21646/"}