# CVE-2021-21646: Remote code execution vulnerability in Jenkins Templating Engine Plugin

> Attackers with Job/Configure permission can execute arbitrary code on the Jenkins controller due to missing script security protections in the Templating Engine Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Apr 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p6qc-37hq-wqr6

## What is CVE-2021-21646?

CVE-2021-21646 is a high-severity code injection vulnerability in Jenkins Templating Engine Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Templating Engine Plugin 2.1 and earlier does not protect its pipeline configurations using Script Security Plugin, allowing attackers with Job/Configure permission to execute arbitrary code in the context of the Jenkins controller JVM.

## Which versions are affected by CVE-2021-21646?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:templating-engine. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:templating-engine` | Maven | All versions | 2.2 |
| `org.jenkins-ci.plugins:templating-engine` | Maven | All versions | 2.2 |

Products: Jenkins Templating Engine.

## How do I fix CVE-2021-21646?

Upgrade org.jenkins-ci.plugins:templating-engine to 2.2 or later.

## Is CVE-2021-21646 being exploited?

There is no known exploitation of CVE-2021-21646 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Templating Engine Plugin

- [CVE-2025-31722](https://insights.sbomify.com/CVE-2025-31722/): Jenkins Templating Engine Plugin Vulnerable to Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21646 and fix it if it is affected.

What it is: CVE-2021-21646 is a high-severity code injection vulnerability in Jenkins Templating Engine Plugin, published on 21 Apr 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21646 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:templating-engine (Maven): affected all versions; fixed in 2.2
- org.jenkins-ci.plugins:templating-engine (Maven): affected all versions; fixed in 2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21646/ (Markdown: https://insights.sbomify.com/CVE-2021-21646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21646
- OSV: https://osv.dev/vulnerability/CVE-2021-21646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21646/
Summaries are generated and may contain mistakes; the official description above is the record.
