CVE-2021-21648 Cross-Site Request Forgery in Jenkins Credentials Plugin
Reflected XSS in Jenkins Credentials Plugin allows attackers to execute arbitrary scripts in victim browsers, potentially leading to session hijacking or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21648?
CVE-2021-21648 is a medium-severity cross-site scripting vulnerability in Jenkins Credentials Plugin, published on 11 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2021-21648?
12 open source packages ship an affected version, including org.jenkins-ci.plugins:credentials. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.plugins:credentials Maven | All versions | 2.3.0.1 |
org.jenkins-ci.plugins:credentials Maven | All versions | 2.3.0.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.1 | 2.3.7.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.1 | 2.3.7.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.14 | 2.3.14.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.14 | 2.3.14.1 |
6 more packages
org.jenkins-ci.plugins:credentials Maven | From 2.3.15 | 2.3.15.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.15 | 2.3.15.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.16 | 2.3.19 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.16 | 2.3.19 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.8 | 2.3.13.1 |
org.jenkins-ci.plugins:credentials Maven | From 2.3.8 | 2.3.13.1 |
Products include Jenkins Credentials.
How do I fix CVE-2021-21648?
Upgrade org.jenkins-ci.plugins:credentials to a fixed version for your release line: 2.3.0.1, 2.3.7.1, 2.3.14.1 or 2.3.15.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-21648 being exploited?
There is no known exploitation of CVE-2021-21648 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Credentials Plugin
- CVE-2024-47805 Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission
- CVE-2022-29036 Cross-site Scripting in Jenkins Credentials Plugin
- CVE-2019-10320 Insertion of Sensitive Information into Externally-Accessible File or Directory in Jenkins Credentials Plugin
Sources
Also known as GHSA-gchq-9r68-6jwv.