# CVE-2021-21648: Cross-Site Request Forgery in Jenkins Credentials Plugin

> Reflected XSS in Jenkins Credentials Plugin allows attackers to execute arbitrary scripts in victim browsers, potentially leading to session hijacking or account takeover.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gchq-9r68-6jwv

## What is CVE-2021-21648?

CVE-2021-21648 is a medium-severity cross-site scripting vulnerability in Jenkins Credentials Plugin, published on 11 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Credentials Plugin 2.3.18 and earlier does not escape user-controlled information on a view it provides, resulting in a reflected cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21648?

12 open source packages ship an affected version, including org.jenkins-ci.plugins:credentials. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:credentials` | Maven | All versions | 2.3.0.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | All versions | 2.3.0.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.1 | 2.3.7.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.1 | 2.3.7.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.14 | 2.3.14.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.14 | 2.3.14.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.15 | 2.3.15.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.15 | 2.3.15.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.16 | 2.3.19 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.16 | 2.3.19 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.8 | 2.3.13.1 |
| `org.jenkins-ci.plugins:credentials` | Maven | From 2.3.8 | 2.3.13.1 |

Products: Jenkins Credentials.

## How do I fix CVE-2021-21648?

Upgrade org.jenkins-ci.plugins:credentials to a fixed version for your release line: 2.3.0.1, 2.3.7.1, 2.3.14.1 or 2.3.15.1.

## Is CVE-2021-21648 being exploited?

There is no known exploitation of CVE-2021-21648 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Credentials Plugin

- [CVE-2024-47805](https://insights.sbomify.com/CVE-2024-47805/): Jenkins Credentials plugin reveals encrypted values of credentials to users with Extended Read permission (high 7.5)
- [CVE-2022-29036](https://insights.sbomify.com/CVE-2022-29036/): Cross-site Scripting in Jenkins Credentials Plugin (medium 5.4)
- [CVE-2019-10320](https://insights.sbomify.com/CVE-2019-10320/): Insertion of Sensitive Information into Externally-Accessible File or Directory in Jenkins Credentials Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21648 and fix it if it is affected.

What it is: CVE-2021-21648 is a medium-severity cross-site scripting vulnerability in Jenkins Credentials Plugin, published on 11 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21648 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.3.0.1
- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.3.0.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.1; fixed in 2.3.7.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.1; fixed in 2.3.7.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.14; fixed in 2.3.14.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.14; fixed in 2.3.14.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.15; fixed in 2.3.15.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.15; fixed in 2.3.15.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.16; fixed in 2.3.19
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.16; fixed in 2.3.19
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.8; fixed in 2.3.13.1
- org.jenkins-ci.plugins:credentials (Maven): affected from 2.3.8; fixed in 2.3.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21648/ (Markdown: https://insights.sbomify.com/CVE-2021-21648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21648
- OSV: https://osv.dev/vulnerability/CVE-2021-21648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21648/
Summaries are generated and may contain mistakes; the official description above is the record.
