CVE-2021-21649 Cross-site Scripting in Jenkins Dashboard View Plugin
Stored XSS in Jenkins Dashboard View Plugin allows attackers with configure permissions to execute scripts via unescaped URLs in image portlets.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21649?
CVE-2021-21649 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 11 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Jenkins Dashboard View Plugin 2.15 and earlier does not escape URLs referenced in Image Dashboard Portlets, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Configure permission.
Weakness: CWE-79
Which versions are affected by CVE-2021-21649?
4 open source packages ship an affected version, including org.jenkins-ci.plugins:dashboard-view. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.plugins:dashboard-view Maven | All versions | 2.12.1 |
org.jenkins-ci.plugins:dashboard-view Maven | All versions | 2.12.1 |
org.jenkins-ci.plugins:dashboard-view Maven | From 2.13 | 2.16 |
org.jenkins-ci.plugins:dashboard-view Maven | From 2.13 | 2.16 |
Products include Jenkins Dashboard View.
How do I fix CVE-2021-21649?
Upgrade org.jenkins-ci.plugins:dashboard-view to a fixed version for your release line: 2.12.1 or 2.16.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-21649 being exploited?
There is no known exploitation of CVE-2021-21649 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Dashboard View Plugin
Sources
Also known as GHSA-jwhm-9cjm-4493.