{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.plugins:dashboard-view. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21649 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:dashboard-view to a fixed version for your release line: 2.12.1 or 2.16.","what":"CVE-2021-21649 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 11 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21649 and fix it if it is affected.\n\nWhat it is: CVE-2021-21649 is a medium-severity cross-site scripting vulnerability in Jenkins Dashboard View Plugin, published on 11 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21649 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.12.1\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected all versions; fixed in 2.12.1\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected from 2.13; fixed in 2.16\n- org.jenkins-ci.plugins:dashboard-view (Maven): affected from 2.13; fixed in 2.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21649/ (Markdown: https://insights.sbomify.com/CVE-2021-21649/index.md)","id":"CVE-2021-21649","markdown":"https://insights.sbomify.com/CVE-2021-21649/index.md","name":"CVE-2021-21649","record":{"aliases":["GHSA-jwhm-9cjm-4493"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Dashboard View Plugin","requires_auth":"low_privilege","summary":"Stored XSS in Jenkins Dashboard View Plugin allows attackers with configure permissions to execute scripts via unescaped URLs in image portlets.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"dashboard_view","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Dashboard View Plugin 2.15 and earlier does not escape URLs referenced in Image Dashboard Portlets, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with View/Configure permission.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Jenkins Dashboard View Plugin","id":"CVE-2021-21649","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Missing Authorization in Jenkins S3 publisher Plugin","id":"CVE-2021-21650"},"packages":[{"ecosystem":"Maven","fixed":["2.12.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":null,"source":"GHSA-jwhm-9cjm-4493"},{"ecosystem":"Maven","fixed":["2.12.1"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":"pkg:maven/org.jenkins-ci.plugins/dashboard-view","source":"GHSA-jwhm-9cjm-4493"},{"ecosystem":"Maven","fixed":["2.16"],"introduced":["2.13"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":null,"source":"GHSA-jwhm-9cjm-4493"},{"ecosystem":"Maven","fixed":["2.16"],"introduced":["2.13"],"last_affected":[],"package":"org.jenkins-ci.plugins:dashboard-view","purl":"pkg:maven/org.jenkins-ci.plugins/dashboard-view","source":"GHSA-jwhm-9cjm-4493"}],"prev":{"headline":"Cross-Site Request Forgery in Jenkins Credentials Plugin","id":"CVE-2021-21648"},"products":["Jenkins Dashboard View Plugin"],"published":"2021-05-11","related":[{"cvss_score":5.4,"headline":"Stored Cross-site Scripting vulnerability in Jenkins Dashboard View Plugin","id":"CVE-2022-27197","kev_date_added":null,"published":"2022-03-15"},{"cvss_score":5.4,"headline":"Jenkins Dashboard View Plugin vulnerable to Cross-site Scripting","id":"CVE-2019-10396","kev_date_added":null,"published":"2019-09-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Dashboard View Plugin allows attackers with configure permissions to execute scripts via unescaped URLs in image portlets.","url":"https://insights.sbomify.com/CVE-2021-21649/"}