{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:p4. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21654 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:p4 to 1.11.5 or later.","what":"CVE-2021-21654 is a medium-severity missing authorization vulnerability in Jenkins P4 Plugin, published on 11 May 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21654 and fix it if it is affected.\n\nWhat it is: CVE-2021-21654 is a medium-severity missing authorization vulnerability in Jenkins P4 Plugin, published on 11 May 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-21654 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.11.5\n- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.11.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21654/ (Markdown: https://insights.sbomify.com/CVE-2021-21654/index.md)","id":"CVE-2021-21654","markdown":"https://insights.sbomify.com/CVE-2021-21654/index.md","name":"CVE-2021-21654","record":{"aliases":["GHSA-h6qv-f5gf-8gcf"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins P4 Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can connect to arbitrary Perforce servers due to missing permission checks in the Jenkins P4 Plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"p4","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[],"description":"Jenkins P4 Plugin 1.11.4 and earlier does not perform permission checks in multiple HTTP endpoints, allowing attackers with Overall/Read permission to connect to an attacker-specified Perforce server using attacker-specified username and password.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing Authorization in Jenkins P4 plugin","id":"CVE-2021-21654","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2021"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-Site Request Forgery in Jenkins P4 Plugin","id":"CVE-2021-21655"},"packages":[{"ecosystem":"Maven","fixed":["1.11.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:p4","purl":null,"source":"GHSA-h6qv-f5gf-8gcf"},{"ecosystem":"Maven","fixed":["1.11.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:p4","purl":"pkg:maven/org.jenkins-ci.plugins/p4","source":"GHSA-h6qv-f5gf-8gcf"}],"prev":{"headline":"Missing Authorization in jenkins xray-connector","id":"CVE-2021-21653"},"products":["Jenkins P4 Plugin"],"published":"2021-05-11","related":[{"cvss_score":7.1,"headline":"Cross-Site Request Forgery in Jenkins P4 Plugin","id":"CVE-2021-21655","kev_date_added":null,"published":"2021-05-11"},{"cvss_score":4.3,"headline":"CSRF vulnerability in Jenkins P4 Plugin","id":"CVE-2020-2141","kev_date_added":null,"published":"2020-03-09"},{"cvss_score":4.3,"headline":"Missing permission checks in Jenkins P4 Plugin","id":"CVE-2020-2142","kev_date_added":null,"published":"2020-03-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can connect to arbitrary Perforce servers due to missing permission checks in the Jenkins P4 Plugin.","url":"https://insights.sbomify.com/CVE-2021-21654/"}