# CVE-2021-21655: Cross-Site Request Forgery in Jenkins P4 Plugin

> Attackers can force users to connect to malicious Perforce servers via CSRF, potentially exposing credentials or data in Jenkins environments.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-3rj3-qp2j-4fj2

## What is CVE-2021-21655?

CVE-2021-21655 is a high-severity vulnerability in Jenkins P4 Plugin, published on 11 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins P4 Plugin 1.11.4 and earlier allows attackers to connect to an attacker-specified Perforce server using attacker-specified username and password.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-21655?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:p4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:p4` | Maven | All versions | 1.11.5 |
| `org.jenkins-ci.plugins:p4` | Maven | All versions | 1.11.5 |

Products: Jenkins P4.

## How do I fix CVE-2021-21655?

Upgrade org.jenkins-ci.plugins:p4 to 1.11.5 or later.

## Is CVE-2021-21655 being exploited?

There is no known exploitation of CVE-2021-21655 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins P4 Plugin

- [CVE-2021-21654](https://insights.sbomify.com/CVE-2021-21654/): Missing Authorization in Jenkins P4 plugin (medium 4.3)
- [CVE-2020-2141](https://insights.sbomify.com/CVE-2020-2141/): CSRF vulnerability in Jenkins P4 Plugin (medium 4.3)
- [CVE-2020-2142](https://insights.sbomify.com/CVE-2020-2142/): Missing permission checks in Jenkins P4 Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21655 and fix it if it is affected.

What it is: CVE-2021-21655 is a high-severity vulnerability in Jenkins P4 Plugin, published on 11 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21655 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.11.5
- org.jenkins-ci.plugins:p4 (Maven): affected all versions; fixed in 1.11.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21655/ (Markdown: https://insights.sbomify.com/CVE-2021-21655/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21655
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21655
- OSV: https://osv.dev/vulnerability/CVE-2021-21655

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21655/
Summaries are generated and may contain mistakes; the official description above is the record.
