# CVE-2021-21660: XSS vulnerability in Jenkins Markdown Formatter Plugin

> Attackers with edit permissions can inject malicious scripts via crafted URLs in Markdown descriptions, leading to stored XSS attacks against Jenkins users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-xqpp-26pp-2365

## What is CVE-2021-21660?

CVE-2021-21660 is a medium-severity cross-site scripting vulnerability in Jenkins Markdown Formatter Plugin, published on 25 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Markdown Formatter Plugin 0.1.0 and earlier does not sanitize crafted link target URLs, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with the ability to edit any description rendered using the configured markup formatter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21660?

2 open source packages ship an affected version, including io.jenkins.plugins:markdown-formatter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:markdown-formatter` | Maven | All versions | 0.2.0 |
| `io.jenkins.plugins:markdown-formatter` | Maven | All versions | 0.2.0 |

Products: Jenkins Markdown Formatter.

## How do I fix CVE-2021-21660?

Upgrade io.jenkins.plugins:markdown-formatter to 0.2.0 or later.

## Is CVE-2021-21660 being exploited?

There is no known exploitation of CVE-2021-21660 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21660 and fix it if it is affected.

What it is: CVE-2021-21660 is a medium-severity cross-site scripting vulnerability in Jenkins Markdown Formatter Plugin, published on 25 May 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21660 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:markdown-formatter (Maven): affected all versions; fixed in 0.2.0
- io.jenkins.plugins:markdown-formatter (Maven): affected all versions; fixed in 0.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21660/ (Markdown: https://insights.sbomify.com/CVE-2021-21660/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21660
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21660
- OSV: https://osv.dev/vulnerability/CVE-2021-21660

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21660/
Summaries are generated and may contain mistakes; the official description above is the record.
