# CVE-2021-21666: Cross-site scripting in Jenkins Kiuwan Plugin

> Reflected XSS in Jenkins Kiuwan Plugin allows attackers to execute arbitrary scripts in victim browsers via unescaped query parameters.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8h77-3xwr-hqhh

## What is CVE-2021-21666?

CVE-2021-21666 is a medium-severity cross-site scripting vulnerability in Jenkins Kiuwan Plugin, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Kiuwan Plugin 1.6.0 and earlier does not escape query parameters in an error message for a form validation endpoint, resulting in a reflected cross-site scripting (XSS) vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21666?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:kiuwanJenkinsPlugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:kiuwanJenkinsPlugin` | Maven | All versions | 1.6.1 |
| `org.jenkins-ci.plugins:kiuwanJenkinsPlugin` | Maven | All versions | 1.6.1 |

Products: Jenkins Kiuwan.

## How do I fix CVE-2021-21666?

Upgrade org.jenkins-ci.plugins:kiuwanJenkinsPlugin to 1.6.1 or later.

## Is CVE-2021-21666 being exploited?

There is no known exploitation of CVE-2021-21666 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21666 and fix it if it is affected.

What it is: CVE-2021-21666 is a medium-severity cross-site scripting vulnerability in Jenkins Kiuwan Plugin, published on 10 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21666 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven): affected all versions; fixed in 1.6.1
- org.jenkins-ci.plugins:kiuwanJenkinsPlugin (Maven): affected all versions; fixed in 1.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21666/ (Markdown: https://insights.sbomify.com/CVE-2021-21666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21666
- OSV: https://osv.dev/vulnerability/CVE-2021-21666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21666/
Summaries are generated and may contain mistakes; the official description above is the record.
