# CVE-2021-21668: Stored XSS vulnerability in Jenkins Scriptler Plugin

> Stored XSS in Jenkins Scriptler Plugin allows attackers with configure permissions to execute scripts in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5c6c-w4c4-vgvx

## What is CVE-2021-21668?

CVE-2021-21668 is a medium-severity cross-site scripting vulnerability in Jenkins Scriptler Plugin, published on 16 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Jenkins Scriptler Plugin 3.1 and earlier does not escape script content, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Scriptler/Configure permission.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-21668?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:scriptler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:scriptler` | Maven | All versions | 3.2 |
| `org.jenkins-ci.plugins:scriptler` | Maven | All versions | 3.2 |

Products: Jenkins Scriptler.

## How do I fix CVE-2021-21668?

Upgrade org.jenkins-ci.plugins:scriptler to 3.2 or later.

## Is CVE-2021-21668 being exploited?

There is no known exploitation of CVE-2021-21668 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Scriptler Plugin

- [CVE-2023-50764](https://insights.sbomify.com/CVE-2023-50764/): Arbitrary file deletion vulnerability in Jenkins Scriptler Plugin (high 8.1)
- [CVE-2021-21700](https://insights.sbomify.com/CVE-2021-21700/): Stored XSS vulnerability in Jenkins Scriptler Plugin (medium 5.4)
- [CVE-2021-21667](https://insights.sbomify.com/CVE-2021-21667/): Stored XSS vulnerability in Jenkins Scriptler Plugin (medium 5.4)
- [CVE-2023-50765](https://insights.sbomify.com/CVE-2023-50765/): Missing permission check in Jenkins Scriptler Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21668 and fix it if it is affected.

What it is: CVE-2021-21668 is a medium-severity cross-site scripting vulnerability in Jenkins Scriptler Plugin, published on 16 Jun 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21668 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:scriptler (Maven): affected all versions; fixed in 3.2
- org.jenkins-ci.plugins:scriptler (Maven): affected all versions; fixed in 3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21668/ (Markdown: https://insights.sbomify.com/CVE-2021-21668/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21668
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21668
- OSV: https://osv.dev/vulnerability/CVE-2021-21668

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21668/
Summaries are generated and may contain mistakes; the official description above is the record.
