CVE-2021-21671 Session fixation vulnerability in Jenkins
Attackers can maintain access via old sessions after a user logs in, potentially leading to account takeover in Jenkins.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-21671?
CVE-2021-21671 is a high-severity vulnerability in Jenkins Jenkins, published on 30 Jun 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Jenkins 2.299 and earlier, LTS 2.289.1 and earlier does not invalidate the previous session on login.
Which versions are affected by CVE-2021-21671?
5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.289.2 |
org.jenkins-ci.main:jenkins-core Maven | All versions | 2.289.2 |
org.jenkins-ci.main:jenkins-core Maven | From 2.292 | 2.300 |
org.jenkins-ci.main:jenkins-core Maven | From 2.292 | 2.300 |
jenkins Bitnami | From 2.266.0 | 2.300.0 |
Products include Jenkins Jenkins.
How do I fix CVE-2021-21671?
Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.289.2 or 2.300.
Is CVE-2021-21671 being exploited?
There is no known exploitation of CVE-2021-21671 in the wild and no public exploit code.
Other vulnerabilities in Jenkins Jenkins
- CVE-2024-23897 Jenkins Command Line Interface (CLI) Path Traversal
- CVE-2018-1000861 Jenkins Stapler Web Framework Deserialization of Untrusted Data
- CVE-2017-1000353 Jenkins Remote Code Execution
- CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure
- CVE-2021-21690 Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins
Sources
Also known as BIT-jenkins-2021-21671, GHSA-4wr9-2xc6-jmg5.