# CVE-2021-21677: RCE vulnerability in Jenkins Code Coverage API Plugin

> Remote attackers can execute arbitrary code by exploiting unsafe deserialization in the Jenkins Code Coverage API Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-58pr-hprx-7hg6

## What is CVE-2021-21677?

CVE-2021-21677 is a high-severity unsafe deserialization vulnerability in Jenkins Code Coverage API Plugin, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Code Coverage API Plugin 1.4.0 and earlier does not apply Jenkins JEP-200 deserialization protection to Java objects it deserializes from disk, resulting in a remote code execution vulnerability.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2021-21677?

2 open source packages ship an affected version, including io.jenkins.plugins:code-coverage-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.4.1 |
| `io.jenkins.plugins:code-coverage-api` | Maven | All versions | 1.4.1 |

Products: Jenkins Code Coverage Api.

## How do I fix CVE-2021-21677?

Upgrade io.jenkins.plugins:code-coverage-api to 1.4.1 or later.

## Is CVE-2021-21677 being exploited?

There is no known exploitation of CVE-2021-21677 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Code Coverage API Plugin

- [CVE-2020-2172](https://insights.sbomify.com/CVE-2020-2172/): XXE vulnerability in Jenkins Code Coverage API Plugin (medium 6.5)
- [CVE-2020-2106](https://insights.sbomify.com/CVE-2020-2106/): Stored XSS vulnerability in Code Coverage API Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21677 and fix it if it is affected.

What it is: CVE-2021-21677 is a high-severity unsafe deserialization vulnerability in Jenkins Code Coverage API Plugin, published on 31 Aug 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21677 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.4.1
- io.jenkins.plugins:code-coverage-api (Maven): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21677/ (Markdown: https://insights.sbomify.com/CVE-2021-21677/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21677
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21677
- OSV: https://osv.dev/vulnerability/CVE-2021-21677

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21677/
Summaries are generated and may contain mistakes; the official description above is the record.
