# CVE-2021-21678: Jenkins SAML Plugin allows bypassing CSRF protection for any URL

> Attackers can craft URLs to bypass CSRF protection in Jenkins via the SAML Plugin, potentially allowing unauthorized actions.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-r5w3-pfq8-3r82

## What is CVE-2021-21678?

CVE-2021-21678 is a high-severity vulnerability in Jenkins SAML Plugin, published on 31 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins SAML Plugin 2.0.7 and earlier allows attackers to craft URLs that would bypass the CSRF protection of any target URL in Jenkins.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2021-21678?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:saml` | Maven | All versions | 2.0.8 |
| `org.jenkins-ci.plugins:saml` | Maven | All versions | 2.0.8 |

Products: Jenkins Saml.

## How do I fix CVE-2021-21678?

Upgrade org.jenkins-ci.plugins:saml to 2.0.8 or later.

## Is CVE-2021-21678 being exploited?

There is no known exploitation of CVE-2021-21678 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins SAML Plugin

- [CVE-2025-64131](https://insights.sbomify.com/CVE-2025-64131/): Jenkins SAML Plugin does not implement a replay cache (high 7.5)
- [CVE-2018-1000602](https://insights.sbomify.com/CVE-2018-1000602/): Jenkins SAML Plugin Session Fixation vulnerability (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21678 and fix it if it is affected.

What it is: CVE-2021-21678 is a high-severity vulnerability in Jenkins SAML Plugin, published on 31 Aug 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21678 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:saml (Maven): affected all versions; fixed in 2.0.8
- org.jenkins-ci.plugins:saml (Maven): affected all versions; fixed in 2.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21678/ (Markdown: https://insights.sbomify.com/CVE-2021-21678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21678
- OSV: https://osv.dev/vulnerability/CVE-2021-21678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21678/
Summaries are generated and may contain mistakes; the official description above is the record.
