# CVE-2021-21681: Password stored in plain text by Jenkins Nomad Plugin

> Attackers with file system access can read unencrypted Docker passwords from the Jenkins controller configuration file.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5c2c-cvg6-ghjm

## What is CVE-2021-21681?

CVE-2021-21681 is a medium-severity vulnerability in Jenkins Nomad Plugin, published on 31 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Jenkins Nomad Plugin 0.7.4 and earlier stores Docker passwords unencrypted in the global config.xml file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2021-21681?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:nomad. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:nomad` | Maven | All versions | 0.7.5 |
| `org.jenkins-ci.plugins:nomad` | Maven | All versions | 0.7.5 |

Products: Jenkins Nomad.

## How do I fix CVE-2021-21681?

Upgrade org.jenkins-ci.plugins:nomad to 0.7.5 or later.

## Is CVE-2021-21681 being exploited?

There is no known exploitation of CVE-2021-21681 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Nomad Plugin

- [CVE-2019-1003092](https://insights.sbomify.com/CVE-2019-1003092/): Cross-site request forgery vulnerability in Jenkins Nomad Plugin (medium 6.5)
- [CVE-2019-1003093](https://insights.sbomify.com/CVE-2019-1003093/): Jenkins Nomad Plugin missing permission check (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21681 and fix it if it is affected.

What it is: CVE-2021-21681 is a medium-severity vulnerability in Jenkins Nomad Plugin, published on 31 Aug 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21681 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:nomad (Maven): affected all versions; fixed in 0.7.5
- org.jenkins-ci.plugins:nomad (Maven): affected all versions; fixed in 0.7.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21681/ (Markdown: https://insights.sbomify.com/CVE-2021-21681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21681
- OSV: https://osv.dev/vulnerability/CVE-2021-21681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21681/
Summaries are generated and may contain mistakes; the official description above is the record.
