# CVE-2021-21683: Path traversal vulnerability on Windows in Jenkins

> Attackers with specific permissions can read arbitrary files on Windows Jenkins controllers or agents due to path traversal in the file browser.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-jenkins-2021-21683, GHSA-4pw5-r58h-fv24

## What is CVE-2021-21683?

CVE-2021-21683 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The file browser in Jenkins 2.314 and earlier, LTS 2.303.1 and earlier may interpret some paths to files as absolute on Windows, resulting in a path traversal vulnerability allowing attackers with Overall/Read permission (Windows controller) or Job/Workspace permission (Windows agents) to obtain the contents of arbitrary files.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-21683?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.303.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.303.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.304 | 2.315 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.304 | 2.315 |
| `jenkins` | Bitnami | All versions | 2.314.1 |

Products: Jenkins Jenkins.

## How do I fix CVE-2021-21683?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.303.2 or 2.315.

## Is CVE-2021-21683 being exploited?

There is no known exploitation of CVE-2021-21683 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21683 and fix it if it is affected.

What it is: CVE-2021-21683 is a medium-severity path traversal vulnerability in Jenkins Jenkins, published on 6 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21683 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.303.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.303.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.304; fixed in 2.315
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.304; fixed in 2.315
- jenkins (Bitnami): affected all versions; fixed in 2.314.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21683/ (Markdown: https://insights.sbomify.com/CVE-2021-21683/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21683
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21683
- OSV: https://osv.dev/vulnerability/CVE-2021-21683

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21683/
Summaries are generated and may contain mistakes; the official description above is the record.
