{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21684 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:git to 4.8.3 or later.","what":"CVE-2021-21684 is a medium-severity cross-site scripting vulnerability in Jenkins Git Plugin, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21684 and fix it if it is affected.\n\nWhat it is: CVE-2021-21684 is a medium-severity cross-site scripting vulnerability in Jenkins Git Plugin, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21684 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.8.3\n- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21684/ (Markdown: https://insights.sbomify.com/CVE-2021-21684/index.md)","id":"CVE-2021-21684","markdown":"https://insights.sbomify.com/CVE-2021-21684/index.md","name":"CVE-2021-21684","record":{"aliases":["GHSA-gghc-g8cj-4vfv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Git Plugin","requires_auth":"none","summary":"Stored XSS in Jenkins Git Plugin allows attackers to execute scripts via unescaped Git SHA-1 checksums in build causes.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"git","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-116","name":"Improper Encoding or Escaping of Output"}],"description":"Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Git Plugin","id":"CVE-2021-21684","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21685"},"packages":[{"ecosystem":"Maven","fixed":["4.8.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":null,"source":"GHSA-gghc-g8cj-4vfv"},{"ecosystem":"Maven","fixed":["4.8.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:git","purl":"pkg:maven/org.jenkins-ci.plugins/git","source":"GHSA-gghc-g8cj-4vfv"}],"prev":{"headline":"Path traversal vulnerability on Windows in Jenkins","id":"CVE-2021-21683"},"products":["Jenkins Git Plugin"],"published":"2021-10-06","related":[{"cvss_score":8.8,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36882","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Lack of authentication mechanism in Jenkins Git Plugin webhook","id":"CVE-2022-36883","kev_date_added":null,"published":"2022-07-27"},{"cvss_score":7.5,"headline":"Path traversal in Jenkins Git Mercurial and Repo Plugins","id":"CVE-2022-30947","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":7.5,"headline":"Cross-Site Request Forgery in Jenkins Git Plugin","id":"CVE-2017-1000092","kev_date_added":null,"published":"2017-10-04"},{"cvss_score":6.5,"headline":"Improper masking of credentials Jenkins in Git Plugin","id":"CVE-2022-38663","kev_date_added":null,"published":"2022-08-23"},{"cvss_score":6.4,"headline":"Server-Side Request Forgery in Jenkins Git Plugin","id":"CVE-2018-1000182","kev_date_added":null,"published":"2018-06-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Stored XSS in Jenkins Git Plugin allows attackers to execute scripts via unescaped Git SHA-1 checksums in build causes.","url":"https://insights.sbomify.com/CVE-2021-21684/"}