# CVE-2021-21684: Stored XSS vulnerability in Jenkins Git Plugin

> Stored XSS in Jenkins Git Plugin allows attackers to execute scripts via unescaped Git SHA-1 checksums in build causes.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gghc-g8cj-4vfv

## What is CVE-2021-21684?

CVE-2021-21684 is a medium-severity cross-site scripting vulnerability in Jenkins Git Plugin, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Jenkins Git Plugin 4.8.2 and earlier does not escape the Git SHA-1 checksum parameters provided to commit notifications when displaying them in a build cause, resulting in a stored cross-site scripting (XSS) vulnerability.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2021-21684?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.8.3 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.8.3 |

Products: Jenkins Git.

## How do I fix CVE-2021-21684?

Upgrade org.jenkins-ci.plugins:git to 4.8.3 or later.

## Is CVE-2021-21684 being exploited?

There is no known exploitation of CVE-2021-21684 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git Plugin

- [CVE-2022-36882](https://insights.sbomify.com/CVE-2022-36882/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 8.8)
- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2022-30947](https://insights.sbomify.com/CVE-2022-30947/): Path traversal in Jenkins Git Mercurial and Repo Plugins (high 7.5)
- [CVE-2017-1000092](https://insights.sbomify.com/CVE-2017-1000092/): Cross-Site Request Forgery in Jenkins Git Plugin (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21684 and fix it if it is affected.

What it is: CVE-2021-21684 is a medium-severity cross-site scripting vulnerability in Jenkins Git Plugin, published on 6 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21684 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.8.3
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21684/ (Markdown: https://insights.sbomify.com/CVE-2021-21684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21684
- OSV: https://osv.dev/vulnerability/CVE-2021-21684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21684/
Summaries are generated and may contain mistakes; the official description above is the record.
