# CVE-2021-21686: Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins

> Attackers can bypass file path filters via symbolic links to access or modify files outside allowed directories in Jenkins.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Nov 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-jenkins-2021-21686, GHSA-4g38-hrm4-rg94

## What is CVE-2021-21686?

CVE-2021-21686 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 4 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

File path filters in the agent-to-controller security subsystem of Jenkins 2.318 and earlier, LTS 2.303.2 and earlier do not canonicalize paths, allowing operations to follow symbolic links to outside allowed directories.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2021-21686?

5 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core and jenkins. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.303.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.303.3 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.304 | 2.319 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.304 | 2.319 |
| `jenkins` | Bitnami | All versions | 2.319.0 |

Products: Jenkins Jenkins.

## How do I fix CVE-2021-21686?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.303.3 or 2.319.

## Is CVE-2021-21686 being exploited?

There is no known exploitation of CVE-2021-21686 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21686 and fix it if it is affected.

What it is: CVE-2021-21686 is a high-severity path traversal vulnerability in Jenkins Jenkins, published on 4 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21686 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.303.3
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.303.3
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.304; fixed in 2.319
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.304; fixed in 2.319
- jenkins (Bitnami): affected all versions; fixed in 2.319.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21686/ (Markdown: https://insights.sbomify.com/CVE-2021-21686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21686
- OSV: https://osv.dev/vulnerability/CVE-2021-21686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21686/
Summaries are generated and may contain mistakes; the official description above is the record.
