{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:scriptler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-21700 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:scriptler to 3.4 or later.","what":"CVE-2021-21700 is a medium-severity cross-site scripting vulnerability in Jenkins Scriptler Plugin, published on 12 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21700 and fix it if it is affected.\n\nWhat it is: CVE-2021-21700 is a medium-severity cross-site scripting vulnerability in Jenkins Scriptler Plugin, published on 12 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21700 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:scriptler (Maven): affected all versions; fixed in 3.4\n- org.jenkins-ci.plugins:scriptler (Maven): affected all versions; fixed in 3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21700/ (Markdown: https://insights.sbomify.com/CVE-2021-21700/index.md)","id":"CVE-2021-21700","markdown":"https://insights.sbomify.com/CVE-2021-21700/index.md","name":"CVE-2021-21700","record":{"aliases":["GHSA-f9gf-2q87-5m44"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Scriptler Plugin","requires_auth":"low_privilege","summary":"Attackers with script creation privileges can execute arbitrary JavaScript in other users' browsers via stored XSS in the Jenkins Scriptler Plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"scriptler","vendor":"jenkins"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Jenkins Scriptler Plugin 3.3 and earlier does not escape the name of scripts on the UI when asking to confirm their deletion, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by exploitable by attackers able to create Scriptler scripts.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Stored XSS vulnerability in Jenkins Scriptler Plugin","id":"CVE-2021-21700","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"XXE vulnerability in Jenkins Performance Plugin","id":"CVE-2021-21701"},"packages":[{"ecosystem":"Maven","fixed":["3.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:scriptler","purl":null,"source":"GHSA-f9gf-2q87-5m44"},{"ecosystem":"Maven","fixed":["3.4"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:scriptler","purl":"pkg:maven/org.jenkins-ci.plugins/scriptler","source":"GHSA-f9gf-2q87-5m44"}],"prev":{"headline":"Stored XSS vulnerability in Jenkins Active Choices Plugin","id":"CVE-2021-21699"},"products":["Jenkins Scriptler Plugin"],"published":"2021-11-12","related":[{"cvss_score":8.1,"headline":"Arbitrary file deletion vulnerability in Jenkins Scriptler Plugin","id":"CVE-2023-50764","kev_date_added":null,"published":"2023-12-13"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins Scriptler Plugin","id":"CVE-2021-21667","kev_date_added":null,"published":"2021-06-16"},{"cvss_score":5.4,"headline":"Stored XSS vulnerability in Jenkins Scriptler Plugin","id":"CVE-2021-21668","kev_date_added":null,"published":"2021-06-16"},{"cvss_score":4.3,"headline":"Missing permission check in Jenkins Scriptler Plugin","id":"CVE-2023-50765","kev_date_added":null,"published":"2023-12-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with script creation privileges can execute arbitrary JavaScript in other users' browsers via stored XSS in the Jenkins Scriptler Plugin.","url":"https://insights.sbomify.com/CVE-2021-21700/"}