CVE-2021-21702 Null Dereference in SoapClient
A malicious SOAP server can cause a PHP application to crash by sending malformed XML data, leading to a denial of service.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-21702?
CVE-2021-21702 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.
Weakness: CWE-476
Which versions are affected by CVE-2021-21702?
3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
libphp Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
php Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
php-min Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
Linux distribution packages (23)
php7 SUSE:Enterprise Storage 6 | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.17.1 |
php72 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.60.1 |
php74 SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.19.1 |
php7 SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.17.1 |
php53 SUSE:Linux Enterprise Point of Sale 11 SP3 | All versions | 5.3.17-112.99.2 |
php53 SUSE:Linux Enterprise Server 11 SP4-LTSS | All versions | 5.3.17-112.99.2 |
php7 SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise Server 15-LTSS | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 7.2.5-4.73.1 |
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 7.2.5-4.73.1 |
php72 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.60.1 |
php74 SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.19.1 |
php7 SUSE:Manager Proxy 4.0 | All versions | 7.2.5-4.73.1 |
php7 SUSE:Manager Retail Branch Server 4.0 | All versions | 7.2.5-4.73.1 |
php7 SUSE:Manager Server 4.0 | All versions | 7.2.5-4.73.1 |
php7 openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.15.1 |
php7-test openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.15.1 |
Products include Debian Debian Linux, Netapp Clustered Data Ontap, Oracle Communications Diameter Signaling Router, Php Php.
How do I fix CVE-2021-21702?
Upgrade libphp to a fixed version for your release line: 7.3.27, 7.4.15 or 8.0.2.
Is CVE-2021-21702 being exploited?
There is no known exploitation of CVE-2021-21702 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-libphp-2021-21702, BIT-php-2021-21702, BIT-php-min-2021-21702, CLSA-2022-1659637689, CLSA-2022-1659638964, DEBIAN-CVE-2021-21702 and 10 more.