# CVE-2021-21702: Null Dereference in SoapClient

> A malicious SOAP server can cause a PHP application to crash by sending malformed XML data, leading to a denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Feb 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2021-21702, BIT-php-2021-21702, BIT-php-min-2021-21702, CLSA-2022-1659637689, CLSA-2022-1659638964, DEBIAN-CVE-2021-21702, ECHO-ba7e-8275-8d48, GHSA-5hg4-wc97-mw4m, MGASA-2021-0076, SUSE-SU-2021:0494-1, SUSE-SU-2021:0498-1, SUSE-SU-2021:0522-1, SUSE-SU-2021:0584-1, SUSE-SU-2021:14668-1, UBUNTU-CVE-2021-21702, openSUSE-SU-2021:0305-1

## What is CVE-2021-21702?

CVE-2021-21702 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PHP versions 7.3.x below 7.3.27, 7.4.x below 7.4.15 and 8.0.x below 8.0.2, when using SOAP extension to connect to a SOAP server, a malicious SOAP server could return malformed XML data as a response that would cause PHP to access a null pointer and thus cause a crash.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2021-21702?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
| `php` | Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
| `php-min` | Bitnami | From 7.3.0 | 7.3.27, 7.4.15, 8.0.2 |
| `php7` | SUSE:Enterprise Storage 6 | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 7.4.6-3.17.1 |
| `php72` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.2.5-1.60.1 |
| `php74` | SUSE:Linux Enterprise Module for Web and Scripting 12 | All versions | 7.4.6-1.19.1 |
| `php7` | SUSE:Linux Enterprise Module for Web and Scripting 15 SP2 | All versions | 7.4.6-3.17.1 |
| `php53` | SUSE:Linux Enterprise Point of Sale 11 SP3 | All versions | 5.3.17-112.99.2 |
| `php53` | SUSE:Linux Enterprise Server 11 SP4-LTSS | All versions | 5.3.17-112.99.2 |
| `php7` | SUSE:Linux Enterprise Server 15 SP1-BCL | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 7.2.5-4.73.1 |
| `php72` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.2.5-1.60.1 |
| `php74` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 7.4.6-1.19.1 |
| `php7` | SUSE:Manager Proxy 4.0 | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Manager Retail Branch Server 4.0 | All versions | 7.2.5-4.73.1 |
| `php7` | SUSE:Manager Server 4.0 | All versions | 7.2.5-4.73.1 |
| `php7` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.15.1 |
| `php7-test` | openSUSE:Leap 15.2 | All versions | 7.4.6-lp152.2.15.1 |

Products: Debian Debian Linux, Netapp Clustered Data Ontap, Oracle Communications Diameter Signaling Router, Php Php.

## How do I fix CVE-2021-21702?

Upgrade libphp to a fixed version for your release line: 7.3.27, 7.4.15 or 8.0.2.

## Is CVE-2021-21702 being exploited?

There is no known exploitation of CVE-2021-21702 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21702 and fix it if it is affected.

What it is: CVE-2021-21702 is a medium-severity vulnerability in Debian Debian Linux, published on 15 Feb 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-21702 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.3.0; fixed in 7.3.27, 7.4.15, 8.0.2
- php (Bitnami): affected from 7.3.0; fixed in 7.3.27, 7.4.15, 8.0.2
- php-min (Bitnami): affected from 7.3.0; fixed in 7.3.27, 7.4.15, 8.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21702/ (Markdown: https://insights.sbomify.com/CVE-2021-21702/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21702
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21702
- OSV: https://osv.dev/vulnerability/CVE-2021-21702

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21702/
Summaries are generated and may contain mistakes; the official description above is the record.
