CVE-2021-21704 Multiple vulnerabilities in Firebird client extension

Medium 5.0 Published Updated

A malicious Firebird database server can trigger memory corruption and denial of service in PHP applications using the Firebird PDO driver.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-21704?

CVE-2021-21704 is a medium-severity memory corruption vulnerability in Netapp Clustered Data Ontap, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using Firebird PDO driver extension, a malicious database server could cause crashes in various database functions, such as getAttribute(), execute(), fetch() and others by returning invalid response data that is not parsed correctly by the driver. This can result in crashes, denial of service or potentially memory corruption.

Weakness: CWE-787, CWE-190, CWE-125

Which versions are affected by CVE-2021-21704?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 2 products.

PackageAffectedFixed in
libphp BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
php BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
php-min BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
Linux distribution packages (16)
php7 SUSE:Enterprise Storage 6All versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-ESPOSAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSSAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise High Performance Computing 15-ESPOSAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise High Performance Computing 15-LTSSAll versions7.2.5-4.79.1
php72 SUSE:Linux Enterprise Module for Web and Scripting 12All versions7.2.5-1.66.1
php7 SUSE:Linux Enterprise Server 15 SP1-BCLAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise Server 15 SP1-LTSSAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise Server 15-LTSSAll versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15All versions7.2.5-4.79.1
php7 SUSE:Linux Enterprise Server for SAP Applications 15 SP1All versions7.2.5-4.79.1
php72 SUSE:Linux Enterprise Software Development Kit 12 SP5All versions7.2.5-1.66.1
php7 SUSE:Manager Proxy 4.0All versions7.2.5-4.79.1
php7 SUSE:Manager Retail Branch Server 4.0All versions7.2.5-4.79.1
php7 SUSE:Manager Server 4.0All versions7.2.5-4.79.1
php7 openSUSE:Leap 15.3All versions7.2.5-4.79.1

Products include Netapp Clustered Data Ontap, Php Php.

How do I fix CVE-2021-21704?

Upgrade libphp to a fixed version for your release line: 7.3.29, 7.4.21 or 8.0.8.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2021-21704 being exploited?

There is no known exploitation of CVE-2021-21704 in the wild and no public exploit code.

All Netapp Clustered Data Ontap vulnerabilities

Sources

Also known as BIT-libphp-2021-21704, BIT-php-2021-21704, BIT-php-min-2021-21704, DEBIAN-CVE-2021-21704, ECHO-fa97-935d-c387, GHSA-q773-v75g-5rqg and 4 more.

Is CVE-2021-21704 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free