CVE-2021-21705 Incorrect URL validation in FILTER_VALIDATE_URL

Medium 4.3 Published Updated

Incorrect URL validation in PHP's filter_var allows accepting invalid URLs, potentially leading to wrong server contact or access decisions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-21705?

CVE-2021-21705 is a medium-severity vulnerability in Netapp Clustered Data Ontap, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.

Weakness: CWE-20

Which versions are affected by CVE-2021-21705?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.

PackageAffectedFixed in
libphp BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
php BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
php-min BitnamiFrom 7.3.07.3.29, 7.4.21, 8.0.8
Linux distribution packages (3)
php72 SUSE:Linux Enterprise Module for Web and Scripting 12All versions7.2.5-1.63.2
php72 SUSE:Linux Enterprise Software Development Kit 12 SP5All versions7.2.5-1.63.2
php7 openSUSE:Leap 15.3All versions7.2.5-4.76.5

Products include Netapp Clustered Data Ontap, Oracle Sd-Wan Aware, Php Php.

How do I fix CVE-2021-21705?

Upgrade libphp to a fixed version for your release line: 7.3.29, 7.4.21 or 8.0.8.

Is CVE-2021-21705 being exploited?

There is no known exploitation of CVE-2021-21705 in the wild and no public exploit code.

All Netapp Clustered Data Ontap vulnerabilities

Sources

Also known as BIT-libphp-2021-21705, BIT-php-2021-21705, BIT-php-min-2021-21705, CLSA-2022-1654526233, CLSA-2022-1654526615, DEBIAN-CVE-2021-21705 and 5 more.

Is CVE-2021-21705 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free