{"answers":{"affected":"3 open source packages ship an affected version, including libphp, php and php-min. It affects 3 products.","exploited":"There is no known exploitation of CVE-2021-21705 in the wild and no public exploit code.","fix":"Upgrade libphp to a fixed version for your release line: 7.3.29, 7.4.21 or 8.0.8.","what":"CVE-2021-21705 is a medium-severity vulnerability in Netapp Clustered Data Ontap, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-21705 and fix it if it is affected.\n\nWhat it is: CVE-2021-21705 is a medium-severity vulnerability in Netapp Clustered Data Ontap, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-21705 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- libphp (Bitnami): affected from 7.3.0; fixed in 7.3.29, 7.4.21, 8.0.8\n- php (Bitnami): affected from 7.3.0; fixed in 7.3.29, 7.4.21, 8.0.8\n- php-min (Bitnami): affected from 7.3.0; fixed in 7.3.29, 7.4.21, 8.0.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21705/ (Markdown: https://insights.sbomify.com/CVE-2021-21705/index.md)","id":"CVE-2021-21705","markdown":"https://insights.sbomify.com/CVE-2021-21705/index.md","name":"CVE-2021-21705","record":{"aliases":["BIT-libphp-2021-21705","BIT-php-2021-21705","BIT-php-min-2021-21705","CLSA-2022-1654526233","CLSA-2022-1654526615","DEBIAN-CVE-2021-21705","ECHO-e319-72a4-3c9f","GHSA-rxcr-7xjm-f9c9","SUSE-SU-2021:2564-1","UBUNTU-CVE-2021-21705","openSUSE-SU-2021:2575-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP core library","requires_auth":"none","summary":"Incorrect URL validation in PHP's filter_var allows accepting invalid URLs, potentially leading to wrong server contact or access decisions.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"php","cpe":[{"product":"clustered_data_ontap","vendor":"netapp"},{"product":"sd-wan_aware","vendor":"oracle"},{"product":"php","vendor":"php"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"In PHP versions 7.3.x below 7.3.29, 7.4.x below 7.4.21 and 8.0.x below 8.0.8, when using URL validation functionality via filter_var() function with FILTER_VALIDATE_URL parameter, an URL with invalid password field can be accepted as valid. This can lead to the code incorrectly parsing the URL and potentially leading to other security implications - like contacting a wrong server or making a wrong access decision.","ecosystems":["Bitnami","SUSE:Linux Enterprise Module for Web and Scripting 12","SUSE:Linux Enterprise Software Development Kit 12 SP5","openSUSE:Leap 15.3"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect URL validation in FILTER_VALIDATE_URL","id":"CVE-2021-21705","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"netapp:clustered_data_ontap","products":["netapp:clustered_data_ontap","php:php"],"type":"other","year":"2021"},"n_packages":6,"n_references":4,"next":{"headline":"ZipArchive::extractTo may extract outside of destination dir","id":"CVE-2021-21706"},"packages":[{"ecosystem":"Bitnami","fixed":["7.3.29","7.4.21","8.0.8"],"introduced":["7.3.0","7.4.0","8.0.0"],"last_affected":[],"package":"libphp","purl":"pkg:bitnami/libphp","source":"BIT-libphp-2021-21705"},{"ecosystem":"Bitnami","fixed":["7.3.29","7.4.21","8.0.8"],"introduced":["7.3.0","7.4.0","8.0.0"],"last_affected":[],"package":"php","purl":"pkg:bitnami/php","source":"BIT-php-2021-21705"},{"ecosystem":"Bitnami","fixed":["7.3.29","7.4.21","8.0.8"],"introduced":["7.3.0","7.4.0","8.0.0"],"last_affected":[],"package":"php-min","purl":"pkg:bitnami/php-min","source":"BIT-php-min-2021-21705"},{"ecosystem":"SUSE:Linux Enterprise Module for Web and Scripting 12","fixed":["7.2.5-1.63.2"],"introduced":["0"],"last_affected":[],"package":"php72","purl":"pkg:rpm/suse/php72\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Web%20and%20Scripting%2012","source":"SUSE-SU-2021:2564-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["7.2.5-1.63.2"],"introduced":["0"],"last_affected":[],"package":"php72","purl":"pkg:rpm/suse/php72\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2021:2564-1"},{"ecosystem":"openSUSE:Leap 15.3","fixed":["7.2.5-4.76.5"],"introduced":["0"],"last_affected":[],"package":"php7","purl":"pkg:rpm/opensuse/php7\u0026distro=openSUSE%20Leap%2015.3","source":"openSUSE-SU-2021:2575-1"}],"prev":{"headline":"Multiple vulnerabilities in Firebird client extension","id":"CVE-2021-21704"},"products":["PHP"],"published":"2021-10-04","related":[{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2015-7853","kev_date_added":null,"published":"2017-08-07"},{"cvss_score":9.8,"headline":"Denial of service in n/a","id":"CVE-2017-9119","kev_date_added":null,"published":"2017-05-21"},{"cvss_score":9.8,"headline":"Deserialization in PHP before 7.0.12","id":"CVE-2016-7480","kev_date_added":null,"published":"2017-01-11"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2017-5340","kev_date_added":null,"published":"2017-01-11"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2017-11147","kev_date_added":null,"published":"2017-07-10"},{"cvss_score":8.8,"headline":"Missing authorization in Clustered Data ONTAP","id":"CVE-2018-5490","kev_date_added":null,"published":"2018-08-03"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2017-12421","kev_date_added":null,"published":"2017-09-01"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["PHP Group"]},"summary":"Incorrect URL validation in PHP's filter_var allows accepting invalid URLs, potentially leading to wrong server contact or access decisions.","url":"https://insights.sbomify.com/CVE-2021-21705/"}