# CVE-2021-21706: ZipArchive::extractTo may extract outside of destination dir

> Attackers can exploit ZipArchive::extractTo in PHP on Windows to write files outside the intended directory, potentially overwriting critical files or executing code.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Oct 2021
- **Updated:** 16 Sep 2024
- **Also known as:** BIT-libphp-2021-21706, BIT-php-2021-21706, BIT-php-min-2021-21706, ECHO-6fd1-b740-5dbb, GHSA-x4g4-47f7-vvq4

## What is CVE-2021-21706?

CVE-2021-21706 is a medium-severity path traversal vulnerability in Php Php, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In PHP versions 7.3.x below 7.3.31, 7.4.x below 7.4.24 and 8.0.x below 8.0.11, in Microsoft Windows environment, ZipArchive::extractTo may be tricked into writing a file outside target directory when extracting a ZIP file, thus potentially causing files to be created or overwritten, subject to OS permissions.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory), CWE-24 (Path Traversal: '../filedir')

## Which versions are affected by CVE-2021-21706?

3 open source packages ship an affected version, including libphp, php and php-min. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libphp` | Bitnami | From 7.3.0 | 7.3.31, 7.4.24, 8.0.11 |
| `php` | Bitnami | From 7.3.0 | 7.3.31, 7.4.24, 8.0.11 |
| `php-min` | Bitnami | From 7.3.0 | 7.3.31, 7.4.24, 8.0.11 |

Products: Php Php.

## How do I fix CVE-2021-21706?

Upgrade libphp to a fixed version for your release line: 7.3.31, 7.4.24 or 8.0.11.

## Is CVE-2021-21706 being exploited?

There is no known exploitation of CVE-2021-21706 in the wild and no public exploit code.

## Other vulnerabilities in Php Php

- [CVE-2012-2688](https://insights.sbomify.com/CVE-2012-2688/): Integer overflow in n/a (critical 10.0)
- [CVE-2012-2376](https://insights.sbomify.com/CVE-2012-2376/): Memory corruption in n/a (critical 10.0)
- [CVE-2011-3268](https://insights.sbomify.com/CVE-2011-3268/): Memory corruption in n/a (critical 10.0)
- [CVE-2009-4143](https://insights.sbomify.com/CVE-2009-4143/): Other in n/a (critical 10.0)
- [CVE-2008-5557](https://insights.sbomify.com/CVE-2008-5557/): Memory corruption in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21706 and fix it if it is affected.

What it is: CVE-2021-21706 is a medium-severity path traversal vulnerability in Php Php, published on 4 Oct 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-21706 in the wild and no public exploit code.

Affected packages and fixed versions:
- libphp (Bitnami): affected from 7.3.0; fixed in 7.3.31, 7.4.24, 8.0.11
- php (Bitnami): affected from 7.3.0; fixed in 7.3.31, 7.4.24, 8.0.11
- php-min (Bitnami): affected from 7.3.0; fixed in 7.3.31, 7.4.24, 8.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21706/ (Markdown: https://insights.sbomify.com/CVE-2021-21706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21706
- OSV: https://osv.dev/vulnerability/CVE-2021-21706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21706/
Summaries are generated and may contain mistakes; the official description above is the record.
