{"answers":{"affected":"3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21809 exists.","fix":"Apply the vendor's patch.","what":"CVE-2021-21809 is a high-severity command injection vulnerability in Moodle Moodle, published on 23 Jun 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-21809 and fix it if it is affected.\n\nWhat it is: CVE-2021-21809 is a high-severity command injection vulnerability in Moodle Moodle, published on 23 Jun 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21809 exists.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; no fix listed\n- moodle/moodle (Packagist): affected all versions; no fix listed\n- moodle (Bitnami): affected from 3.10.0; fixed in 3.10.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-21809/ (Markdown: https://insights.sbomify.com/CVE-2021-21809/index.md)","id":"CVE-2021-21809","markdown":"https://insights.sbomify.com/CVE-2021-21809/index.md","name":"CVE-2021-21809","record":{"aliases":["BIT-moodle-2021-21809","GHSA-c7jj-vfmr-j9mj","UBUNTU-CVE-2021-21809"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"high_privilege","summary":"An administrator can execute arbitrary commands via the legacy spellchecker plugin in Moodle.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":"2021-06-22","github_poc":1,"max_poc_stars":1,"metasploit":1,"nuclei":0,"refs":[{"date":"2022-12-20T01:44:49Z","kind":"github_poc","ref":"https://github.com/anldori/CVE-2021-21809","stars":1,"title":"CVE-2021-21809 POC"},{"date":"2021-06-22","kind":"metasploit","ref":"exploit/multi/http/moodle_spelling_path_rce","stars":null,"title":"Moodle SpellChecker Path Authenticated Remote Command Execution"}],"tier":"weaponised"},"has_fix":true,"headline":"Moodle command execution vulnerability exists in the default legacy spellchecker plugin","id":"CVE-2021-21809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"moodle:moodle","products":["moodle:moodle"],"type":"command_injection","year":"2021"},"n_packages":3,"n_references":2,"next":{"headline":"Memory corruption in AT\u0026T Labs","id":"CVE-2021-21810"},"packages":[{"ecosystem":"Bitnami","fixed":["3.10.1"],"introduced":["3.10.0"],"last_affected":[],"package":"moodle","purl":"pkg:bitnami/moodle","source":"BIT-moodle-2021-21809"},{"ecosystem":"Packagist","fixed":[],"introduced":[],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-c7jj-vfmr-j9mj"},{"ecosystem":"Packagist","fixed":[],"introduced":[],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-c7jj-vfmr-j9mj"}],"prev":{"headline":"Memory corruption in Accusoft","id":"CVE-2021-21808"},"products":["Moodle"],"published":"2021-06-23","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"An administrator can execute arbitrary commands via the legacy spellchecker plugin in Moodle.","url":"https://insights.sbomify.com/CVE-2021-21809/"}