# CVE-2021-21809: Moodle command execution vulnerability exists in the default legacy spellchecker plugin

> An administrator can execute arbitrary commands via the legacy spellchecker plugin in Moodle.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-moodle-2021-21809, GHSA-c7jj-vfmr-j9mj, UBUNTU-CVE-2021-21809

## What is CVE-2021-21809?

CVE-2021-21809 is a high-severity command injection vulnerability in Moodle Moodle, published on 23 Jun 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A command execution vulnerability exists in the default legacy spellchecker plugin in Moodle 3.10. A specially crafted series of HTTP requests can lead to command execution. An attacker must have administrator privileges to exploit this vulnerabilities.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-21809?

3 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | All versions | None |
| `moodle/moodle` | Packagist | All versions | None |
| `moodle` | Bitnami | From 3.10.0 | 3.10.1 |

Products: Moodle Moodle.

## How do I fix CVE-2021-21809?

Apply the vendor's patch.

## Is CVE-2021-21809 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21809 exists.

Public exploit code:

- CVE-2021-21809 POC (github_poc): https://github.com/anldori/CVE-2021-21809
- Moodle SpellChecker Path Authenticated Remote Command Execution (metasploit)

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-21809 and fix it if it is affected.

What it is: CVE-2021-21809 is a high-severity command injection vulnerability in Moodle Moodle, published on 23 Jun 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-21809 exists.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected all versions; no fix listed
- moodle/moodle (Packagist): affected all versions; no fix listed
- moodle (Bitnami): affected from 3.10.0; fixed in 3.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-21809/ (Markdown: https://insights.sbomify.com/CVE-2021-21809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-21809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-21809
- OSV: https://osv.dev/vulnerability/CVE-2021-21809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-21809/
Summaries are generated and may contain mistakes; the official description above is the record.
