CVE-2021-22044 Exposure of Resource to Wrong Sphere in Spring Cloud OpenFeign
Attackers can access unintended endpoints when Feign clients use type-level RequestMapping annotations, potentially exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2021-22044?
CVE-2021-22044 is a high-severity vulnerability in Spring Cloud OpenFeign, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Spring Cloud OpenFeign 3.0.0 to 3.0.4, 2.2.0.RELEASE to 2.2.9.RELEASE, and older unsupported versions, applications using type-level `@RequestMapping`annotations over Feign client interfaces, can be involuntarily exposing endpoints corresponding to `@RequestMapping`-annotated interface methods.
Which versions are affected by CVE-2021-22044?
4 open source packages ship an affected version, including org.springframework.cloud:spring-cloud-openfeign-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework.cloud:spring-cloud-openfeign-core Maven | From 2.2.0 | 2.2.10 |
org.springframework.cloud:spring-cloud-openfeign-core Maven | From 2.2.0 | 2.2.10 |
org.springframework.cloud:spring-cloud-openfeign-core Maven | From 3.0.0 | 3.0.5 |
org.springframework.cloud:spring-cloud-openfeign-core Maven | From 3.0.0 | 3.0.5 |
Products include Vmware Spring Cloud Openfeign.
How do I fix CVE-2021-22044?
Upgrade org.springframework.cloud:spring-cloud-openfeign-core to a fixed version for your release line: 2.2.10 or 3.0.5.
Is CVE-2021-22044 being exploited?
There is no known exploitation of CVE-2021-22044 in the wild and no public exploit code.
Sources
Also known as GHSA-pf94-6v2v-cm3j.