# CVE-2021-22047: Exposure of Resource to Wrong Sphere in Spring Data REST

> Custom controllers may expose resources under unintended URIs, potentially allowing unauthorized data access if Spring Security is not configured to block them.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-4926-qpxg-6r3w

## What is CVE-2021-22047?

CVE-2021-22047 is a medium-severity missing authorization vulnerability in Spring Data REST, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Spring Data REST versions 3.4.0 - 3.4.13, 3.5.0 - 3.5.5, and older unsupported versions, HTTP resources implemented by custom controllers using a configured base API path and a controller type-level request mapping are additionally exposed under URIs that can potentially be exposed for unauthorized access depending on the Spring Security configuration.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-22047?

4 open source packages ship an affected version, including org.springframework.data:spring-data-rest-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework.data:spring-data-rest-core` | Maven | From 3.4.0 | 3.4.14 |
| `org.springframework.data:spring-data-rest-core` | Maven | From 3.4.0 | 3.4.14 |
| `org.springframework.data:spring-data-rest-core` | Maven | From 3.5.0 | 3.5.6 |
| `org.springframework.data:spring-data-rest-core` | Maven | From 3.5.0 | 3.5.6 |

Products: Vmware Spring Data Rest.

## How do I fix CVE-2021-22047?

Upgrade org.springframework.data:spring-data-rest-core to a fixed version for your release line: 3.4.14 or 3.5.6.

## Is CVE-2021-22047 being exploited?

There is no known exploitation of CVE-2021-22047 in the wild and no public exploit code.

## Other vulnerabilities in Spring Data REST

- [CVE-2026-41729](https://insights.sbomify.com/CVE-2026-41729/): Spring Data REST SpEL Injection via Map Key in JSON Patch (high 8.1)
- [CVE-2026-41728](https://insights.sbomify.com/CVE-2026-41728/): Spring Data REST JSON Patch bypasses Jackson read-only property protection on nested objects and collections (high 7.5)
- [CVE-2026-47849](https://insights.sbomify.com/CVE-2026-47849/): Spring Data REST allows mutation of identifier and version properties via JSON Patch (high 7.1)
- [CVE-2026-41730](https://insights.sbomify.com/CVE-2026-41730/): Spring Data REST exposes persistence-layer internals in error responses (medium 5.3)
- [CVE-2026-41837](https://insights.sbomify.com/CVE-2026-41837/): Spring Data REST Querydsl integration exposes Jackson-hidden persistent fields as filter keys (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22047 and fix it if it is affected.

What it is: CVE-2021-22047 is a medium-severity missing authorization vulnerability in Spring Data REST, published on 28 Oct 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22047 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework.data:spring-data-rest-core (Maven): affected from 3.4.0; fixed in 3.4.14
- org.springframework.data:spring-data-rest-core (Maven): affected from 3.4.0; fixed in 3.4.14
- org.springframework.data:spring-data-rest-core (Maven): affected from 3.5.0; fixed in 3.5.6
- org.springframework.data:spring-data-rest-core (Maven): affected from 3.5.0; fixed in 3.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22047/ (Markdown: https://insights.sbomify.com/CVE-2021-22047/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22047
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22047
- OSV: https://osv.dev/vulnerability/CVE-2021-22047

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22047/
Summaries are generated and may contain mistakes; the official description above is the record.
