# CVE-2021-22096: Improper Output Neutralization for Logs in Spring Framework

> Attackers can inject malicious input to insert additional log entries in Spring Framework applications, potentially corrupting audit trails.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1792602142, DEBIAN-CVE-2021-22096, GHSA-rfmp-97jj-h8m6, UBUNTU-CVE-2021-22096

## What is CVE-2021-22096?

CVE-2021-22096 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 28 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Spring Framework versions 5.3.0 - 5.3.10, 5.2.0 - 5.2.17, and older unsupported versions, it is possible for a user to provide malicious input to cause the insertion of additional log entries.

Weakness: CWE-117 (Improper Output Neutralization for Logs)

## Which versions are affected by CVE-2021-22096?

8 open source packages ship an affected version, including org.springframework:spring and org.springframework:spring-core. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring` | Maven | From 5.2.0 | 5.2.18 |
| `org.springframework:spring` | Maven | From 5.2.0 | 5.2.18 |
| `org.springframework:spring` | Maven | From 5.3.0 | 5.3.11 |
| `org.springframework:spring` | Maven | From 5.3.0 | 5.3.11 |
| `org.springframework:spring-core` | Maven | From 5.2.0 | 5.2.18 |
| `org.springframework:spring-core` | Maven | From 5.2.0 | 5.2.18 |
| `org.springframework:spring-core` | Maven | From 5.3.0 | 5.3.11 |
| `org.springframework:spring-core` | Maven | From 5.3.0 | 5.3.11 |

Products: Netapp Active Iq Unified Manager, Netapp Management Services for Element Software and Netapp Hci, Netapp Metrocluster Tiebreaker, Netapp Snap Creator Framework, Netapp Snapcenter, Oracle Communications Cloud Native Core Console, Oracle Communications Cloud Native Core Service Communication Proxy, Vmware Spring Framework.

## How do I fix CVE-2021-22096?

Upgrade org.springframework:spring to a fixed version for your release line: 5.2.18 or 5.3.11.

## Is CVE-2021-22096 being exploited?

There is no known exploitation of CVE-2021-22096 in the wild and no public exploit code.

## Other vulnerabilities in Netapp Active Iq Unified Manager

- [CVE-2022-31692](https://insights.sbomify.com/CVE-2022-31692/): Spring Security authorization rules can be bypassed via forward or include dispatcher types (critical 9.8)
- [CVE-2022-2526](https://insights.sbomify.com/CVE-2022-2526/): Use after free in systemd-resolved (critical 9.8)
- [CVE-2022-22978](https://insights.sbomify.com/CVE-2022-22978/): Authorization bypass in Spring Security (critical 9.8)
- [CVE-2021-22931](https://insights.sbomify.com/CVE-2021-22931/): Code injection in Node (critical 9.8)
- [CVE-2018-2938](https://insights.sbomify.com/CVE-2018-2938/): Code injection in Java (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22096 and fix it if it is affected.

What it is: CVE-2021-22096 is a medium-severity vulnerability in Netapp Active Iq Unified Manager, published on 28 Oct 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22096 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring (Maven): affected from 5.2.0; fixed in 5.2.18
- org.springframework:spring (Maven): affected from 5.2.0; fixed in 5.2.18
- org.springframework:spring (Maven): affected from 5.3.0; fixed in 5.3.11
- org.springframework:spring (Maven): affected from 5.3.0; fixed in 5.3.11
- org.springframework:spring-core (Maven): affected from 5.2.0; fixed in 5.2.18
- org.springframework:spring-core (Maven): affected from 5.2.0; fixed in 5.2.18
- org.springframework:spring-core (Maven): affected from 5.3.0; fixed in 5.3.11
- org.springframework:spring-core (Maven): affected from 5.3.0; fixed in 5.3.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22096/ (Markdown: https://insights.sbomify.com/CVE-2021-22096/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22096
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22096
- OSV: https://osv.dev/vulnerability/CVE-2021-22096

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22096/
Summaries are generated and may contain mistakes; the official description above is the record.
