# CVE-2021-22116: RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint.


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Jun 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-rabbitmq-2021-22116, DEBIAN-CVE-2021-22116, GHSA-5hjq-8gx9-79g4, UBUNTU-CVE-2021-22116

## What is CVE-2021-22116?

CVE-2021-22116 is a high-severity vulnerability in Debian Debian Linux, published on 8 Jun 2021. 

### Official description

RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint. A malicious user can exploit the vulnerability by sending malicious AMQP messages to the target RabbitMQ instance having the AMQP 1.0 plugin enabled.

Weakness: CWE-20 (Improper Input Validation), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-22116?

1 open source package ship an affected version, including rabbitmq. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | All versions | 3.8.16 |

Products: Debian Debian Linux, Vmware Rabbitmq.

## How do I fix CVE-2021-22116?

Upgrade rabbitmq to 3.8.16 or later.

## Is CVE-2021-22116 being exploited?

There is no known exploitation of CVE-2021-22116 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22116 and fix it if it is affected.

What it is: CVE-2021-22116 is a high-severity vulnerability in Debian Debian Linux, published on 8 Jun 2021. 
Exploitation: There is no known exploitation of CVE-2021-22116 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected all versions; fixed in 3.8.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22116/ (Markdown: https://insights.sbomify.com/CVE-2021-22116/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22116
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22116
- OSV: https://osv.dev/vulnerability/CVE-2021-22116

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22116/
Summaries are generated and may contain mistakes; the official description above is the record.
