{"answers":{"affected":"1 open source package ship an affected version, including rabbitmq. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-22117 in the wild and no public exploit code.","fix":"Upgrade rabbitmq to 3.8.16 or later.","what":"CVE-2021-22117 is a high-severity vulnerability in Broadcom Rabbitmq Server, published on 18 May 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-22117 and fix it if it is affected.\n\nWhat it is: CVE-2021-22117 is a high-severity vulnerability in Broadcom Rabbitmq Server, published on 18 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-22117 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rabbitmq (Bitnami): affected from 3.8.0; fixed in 3.8.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-22117/ (Markdown: https://insights.sbomify.com/CVE-2021-22117/index.md)","id":"CVE-2021-22117","markdown":"https://insights.sbomify.com/CVE-2021-22117/index.md","name":"CVE-2021-22117","record":{"aliases":["BIT-rabbitmq-2021-22117","GHSA-rwr9-36p6-24vw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"RabbitMQ Windows installer","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges and execute code by adding arbitrary plugins due to insecure permissions in the RabbitMQ Windows installer.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"vmware","cpe":[{"product":"rabbitmq_server","vendor":"broadcom"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"},{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"RabbitMQ installers on Windows prior to version 3.8.16 do not harden plugin directory permissions, potentially allowing attackers with sufficient local filesystem permissions to add arbitrary plugins.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in RabbitMQ","id":"CVE-2021-22117","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"broadcom:rabbitmq_server","products":["broadcom:rabbitmq_server"],"type":"privilege_escalation","year":"2021"},"n_packages":1,"n_references":1,"next":{"headline":"Improper Privilege Management in Spring Framework","id":"CVE-2021-22118"},"packages":[{"ecosystem":"Bitnami","fixed":["3.8.16"],"introduced":["3.8.0"],"last_affected":[],"package":"rabbitmq","purl":"pkg:bitnami/rabbitmq","source":"BIT-rabbitmq-2021-22117"}],"prev":{"headline":"RabbitMQ all versions prior to 3.8.16 are prone to a denial of service vulnerability due to improper input validation in AMQP 1.0 client connection endpoint.","id":"CVE-2021-22116"},"products":["RabbitMQ"],"published":"2021-05-18","related":[{"cvss_score":9.8,"headline":"Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7","id":"CVE-2016-9877","kev_date_added":null,"published":"2016-12-29"},{"cvss_score":9.2,"headline":"RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch","id":"CVE-2026-67404","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":9.1,"headline":"RabbitMQ: Trust-store whitelist by Issuer+Serial only","id":"CVE-2026-67231","kev_date_added":null,"published":"2026-09-23"},{"cvss_score":8.7,"headline":"Information disclosure in rabbitmq-server","id":"CVE-2026-57219","kev_date_added":null,"published":"2026-07-10"},{"cvss_score":8.2,"headline":"RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login","id":"CVE-2026-67236","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":8.2,"headline":"RabbitMQ: JWKS Fetch Ignores HTTP Response Status Code - Signing Key Destruction Causes Authentication DoS","id":"CVE-2026-67409","kev_date_added":null,"published":"2026-09-25"},{"cvss_score":8.2,"headline":"RabbitMQ: OAuth2 Client Secret Exposed via Unauthenticated JavaScript Endpoint","id":"CVE-2026-67410","kev_date_added":null,"published":"2026-09-25"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Local attackers can escalate privileges and execute code by adding arbitrary plugins due to insecure permissions in the RabbitMQ Windows installer.","url":"https://insights.sbomify.com/CVE-2021-22117/"}