# CVE-2021-22117: Privilege escalation in RabbitMQ

> Local attackers can escalate privileges and execute code by adding arbitrary plugins due to insecure permissions in the RabbitMQ Windows installer.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-rabbitmq-2021-22117, GHSA-rwr9-36p6-24vw

## What is CVE-2021-22117?

CVE-2021-22117 is a high-severity vulnerability in Broadcom Rabbitmq Server, published on 18 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

RabbitMQ installers on Windows prior to version 3.8.16 do not harden plugin directory permissions, potentially allowing attackers with sufficient local filesystem permissions to add arbitrary plugins.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource), CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-22117?

1 open source package ship an affected version, including rabbitmq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rabbitmq` | Bitnami | From 3.8.0 | 3.8.16 |

Products: Broadcom Rabbitmq Server.

## How do I fix CVE-2021-22117?

Upgrade rabbitmq to 3.8.16 or later.

## Is CVE-2021-22117 being exploited?

There is no known exploitation of CVE-2021-22117 in the wild and no public exploit code.

## Other vulnerabilities in Broadcom Rabbitmq Server

- [CVE-2016-9877](https://insights.sbomify.com/CVE-2016-9877/): Auth bypass in Pivotal RabbitMQ 3.x before 3.5.8 and 3.6.x before 3.6.6; RabbitMQ for PCF 1.5.x before 1.5.20, 1.6.x before 1.6.12 and 1.7.x before 1.7.7 (critical 9.8)
- [CVE-2026-67404](https://insights.sbomify.com/CVE-2026-67404/): RabbitMQ: OAuth2 silent verify_none fallback for JWKS fetch (critical 9.2)
- [CVE-2026-67231](https://insights.sbomify.com/CVE-2026-67231/): RabbitMQ: Trust-store whitelist by Issuer+Serial only (critical 9.1)
- [CVE-2026-57219](https://insights.sbomify.com/CVE-2026-57219/): Information disclosure in rabbitmq-server (high 8.7)
- [CVE-2026-67236](https://insights.sbomify.com/CVE-2026-67236/): RabbitMQ: Plaintext username:password stored in an insecure cookie after successful POST /login (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22117 and fix it if it is affected.

What it is: CVE-2021-22117 is a high-severity vulnerability in Broadcom Rabbitmq Server, published on 18 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22117 in the wild and no public exploit code.

Affected packages and fixed versions:
- rabbitmq (Bitnami): affected from 3.8.0; fixed in 3.8.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22117/ (Markdown: https://insights.sbomify.com/CVE-2021-22117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22117
- OSV: https://osv.dev/vulnerability/CVE-2021-22117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22117/
Summaries are generated and may contain mistakes; the official description above is the record.
