CVE-2021-22118 Improper Privilege Management in Spring Framework

High 7.8 Published Updated

A locally authenticated user can escalate privileges to read, modify, or overwrite files in Spring WebFlux applications by manipulating temporary storage directories.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-22118?

CVE-2021-22118 is a high-severity vulnerability in Oracle Commerce Guided Search, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

In Spring Framework, versions 5.2.x prior to 5.2.15 and versions 5.3.x prior to 5.3.7, a WebFlux application is vulnerable to a privilege escalation: by (re)creating the temporary storage directory, a locally authenticated malicious user can read or modify files that have been uploaded to the WebFlux application, or overwrite arbitrary files with multipart request data.

Weakness: CWE-668, CWE-269

Which versions are affected by CVE-2021-22118?

4 open source packages ship an affected version, including org.springframework:spring-web. It affects 32 products.

PackageAffectedFixed in
org.springframework:spring-web MavenFrom 5.2.05.2.15
org.springframework:spring-web MavenFrom 5.2.05.2.15
org.springframework:spring-web MavenFrom 5.3.05.3.7
org.springframework:spring-web MavenFrom 5.3.05.3.7

Products include Netapp Hci, Netapp Management Services for Element Software, Oracle Commerce Guided Search, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Cloud Native Core Policy and 26 more.

How do I fix CVE-2021-22118?

Upgrade org.springframework:spring-web to a fixed version for your release line: 5.2.15 or 5.3.7.

Is CVE-2021-22118 being exploited?

There is no known exploitation of CVE-2021-22118 in the wild and no public exploit code.

Sources

Also known as CLSA-2026-1792687946, GHSA-gfwj-fwqj-fp3v, UBUNTU-CVE-2021-22118.

Is CVE-2021-22118 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free