# CVE-2021-22118: Improper Privilege Management in Spring Framework

> A locally authenticated user can escalate privileges to read, modify, or overwrite files in Spring WebFlux applications by manipulating temporary storage directories.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2021
- **Updated:** 3 Aug 2024
- **Also known as:** CLSA-2026-1792687946, GHSA-gfwj-fwqj-fp3v, UBUNTU-CVE-2021-22118

## What is CVE-2021-22118?

CVE-2021-22118 is a high-severity vulnerability in Oracle Commerce Guided Search, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

In Spring Framework, versions 5.2.x prior to 5.2.15 and versions 5.3.x prior to 5.3.7, a WebFlux application is vulnerable to a privilege escalation: by (re)creating the temporary storage directory, a locally authenticated malicious user can read or modify files that have been uploaded to the WebFlux application, or overwrite arbitrary files with multipart request data.

Weakness: CWE-668 (Exposure of Resource to Wrong Sphere), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2021-22118?

4 open source packages ship an affected version, including org.springframework:spring-web. It affects 32 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-web` | Maven | From 5.2.0 | 5.2.15 |
| `org.springframework:spring-web` | Maven | From 5.2.0 | 5.2.15 |
| `org.springframework:spring-web` | Maven | From 5.3.0 | 5.3.7 |
| `org.springframework:spring-web` | Maven | From 5.3.0 | 5.3.7 |

Products: Netapp Hci, Netapp Management Services for Element Software, Oracle Commerce Guided Search, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Cloud Native Core Policy, Oracle Communications Cloud Native Core Security Edge Protection Proxy, Oracle Communications Cloud Native Core Service Communication Proxy, Oracle Communications Cloud Native Core Unified Data Repository, Oracle Communications Diameter Intelligence Hub, Oracle Communications Element Manager, Oracle Communications Interactive Session Recorder, Oracle Communications Network Integrity, Oracle Communications Session Report Manager, Oracle Communications Session Route Manager, Oracle Communications Unified Inventory Management, Oracle Documaker, Oracle Enterprise Data Quality, Oracle Financial Services Analytical Applications Infrastructure, Oracle Healthcare Data Repository and 12 more.

## How do I fix CVE-2021-22118?

Upgrade org.springframework:spring-web to a fixed version for your release line: 5.2.15 or 5.3.7.

## Is CVE-2021-22118 being exploited?

There is no known exploitation of CVE-2021-22118 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22118 and fix it if it is affected.

What it is: CVE-2021-22118 is a high-severity vulnerability in Oracle Commerce Guided Search, published on 27 May 2021. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22118 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-web (Maven): affected from 5.2.0; fixed in 5.2.15
- org.springframework:spring-web (Maven): affected from 5.2.0; fixed in 5.2.15
- org.springframework:spring-web (Maven): affected from 5.3.0; fixed in 5.3.7
- org.springframework:spring-web (Maven): affected from 5.3.0; fixed in 5.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22118/ (Markdown: https://insights.sbomify.com/CVE-2021-22118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22118
- OSV: https://osv.dev/vulnerability/CVE-2021-22118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22118/
Summaries are generated and may contain mistakes; the official description above is the record.
