CVE-2021-22132 Insufficiently Protected Credentials in Elasticsearch

Medium 4.8 Published Updated

An Elasticsearch user with read access to the .tasks index can obtain sensitive HTTP headers from other users' async search requests.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-22132?

CVE-2021-22132 is a medium-severity vulnerability in Elastic Elasticsearch, published on 14 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Elasticsearch versions 7.7.0 to 7.10.1 contain an information disclosure flaw in the async search API. Users who execute an async search will improperly store the HTTP headers. An Elasticsearch user with the ability to read the .tasks index could obtain sensitive request headers of other users in the cluster. This issue is fixed in Elasticsearch 7.10.2

Weakness: CWE-522

Which versions are affected by CVE-2021-22132?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 2 products.

PackageAffectedFixed in
org.elasticsearch:elasticsearch MavenFrom 7.7.07.10.2
org.elasticsearch:elasticsearch MavenFrom 7.7.07.10.2
elasticsearch BitnamiFrom 7.7.07.10.2

Products include Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.

How do I fix CVE-2021-22132?

Upgrade org.elasticsearch:elasticsearch to 7.10.2 or later.

Is CVE-2021-22132 being exploited?

There is no known exploitation of CVE-2021-22132 in the wild and no public exploit code.

All Elastic Elasticsearch vulnerabilities

Sources

Also known as BIT-elasticsearch-2021-22132, GHSA-5fvx-2jj3-6mff, UBUNTU-CVE-2021-22132.

Is CVE-2021-22132 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free