# CVE-2021-22132: Insufficiently Protected Credentials in Elasticsearch

> An Elasticsearch user with read access to the .tasks index can obtain sensitive HTTP headers from other users' async search requests.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jan 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2021-22132, GHSA-5fvx-2jj3-6mff, UBUNTU-CVE-2021-22132

## What is CVE-2021-22132?

CVE-2021-22132 is a medium-severity vulnerability in Elastic Elasticsearch, published on 14 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Elasticsearch versions 7.7.0 to 7.10.1 contain an information disclosure flaw in the async search API. Users who execute an async search will improperly store the HTTP headers. An Elasticsearch user with the ability to read the .tasks index could obtain sensitive request headers of other users in the cluster. This issue is fixed in Elasticsearch 7.10.2

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2021-22132?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 7.7.0 | 7.10.2 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.7.0 | 7.10.2 |
| `elasticsearch` | Bitnami | From 7.7.0 | 7.10.2 |

Products: Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2021-22132?

Upgrade org.elasticsearch:elasticsearch to 7.10.2 or later.

## Is CVE-2021-22132 being exploited?

There is no known exploitation of CVE-2021-22132 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22132 and fix it if it is affected.

What it is: CVE-2021-22132 is a medium-severity vulnerability in Elastic Elasticsearch, published on 14 Jan 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-22132 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 7.7.0; fixed in 7.10.2
- org.elasticsearch:elasticsearch (Maven): affected from 7.7.0; fixed in 7.10.2
- elasticsearch (Bitnami): affected from 7.7.0; fixed in 7.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22132/ (Markdown: https://insights.sbomify.com/CVE-2021-22132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22132
- OSV: https://osv.dev/vulnerability/CVE-2021-22132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22132/
Summaries are generated and may contain mistakes; the official description above is the record.
