# CVE-2021-22134: Exposure of Sensitive Information to an Unauthorized Actor

> Attackers can view existence of restricted documents and fields in Elasticsearch when Document or Field Level Security is enabled.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2021
- **Updated:** 3 Aug 2024
- **Also known as:** BIT-elasticsearch-2021-22134, GHSA-hwvv-438r-mhvj, UBUNTU-CVE-2021-22134

## What is CVE-2021-22134?

CVE-2021-22134 is a medium-severity vulnerability in Elastic Elasticsearch, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A document disclosure flaw was found in Elasticsearch versions after 7.6.0 and before 7.11.0 when Document or Field Level Security is used. Get requests do not properly apply security permissions when executing a query against a recently updated document. This affects documents that have been updated and not yet refreshed in the index. This could result in the search disclosing the existence of documents and fields the attacker should not be able to view.

Weakness: CWE-863 (Incorrect Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-22134?

3 open source packages ship an affected version, including org.elasticsearch:elasticsearch and elasticsearch. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.elasticsearch:elasticsearch` | Maven | From 7.6.0 | 7.11.0 |
| `org.elasticsearch:elasticsearch` | Maven | From 7.6.0 | 7.11.0 |
| `elasticsearch` | Bitnami | From 7.6.0 | 7.11.1 |

Products: Elastic Elasticsearch, Oracle Communications Cloud Native Core Automated Test Suite.

## How do I fix CVE-2021-22134?

Upgrade org.elasticsearch:elasticsearch to 7.11.0 or later.

## Is CVE-2021-22134 being exploited?

There is no known exploitation of CVE-2021-22134 in the wild and no public exploit code.

## Other vulnerabilities in Elastic Elasticsearch

- [CVE-2015-1427](https://insights.sbomify.com/CVE-2015-1427/): Elasticsearch Groovy Scripting Engine Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2014-3120](https://insights.sbomify.com/CVE-2014-3120/): Elasticsearch Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2015-5377](https://insights.sbomify.com/CVE-2015-5377/): Code injection in n/a (critical 9.8)
- [CVE-2026-72649](https://insights.sbomify.com/CVE-2026-72649/): Deserialization of Untrusted Data in Elasticsearch Leading to Remote Code Execution (high 8.8)
- [CVE-2026-72642](https://insights.sbomify.com/CVE-2026-72642/): Use of Out-of-range Pointer Offset in the Elasticsearch Machine Learning Native Inference Process (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-22134 and fix it if it is affected.

What it is: CVE-2021-22134 is a medium-severity vulnerability in Elastic Elasticsearch, published on 8 Mar 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-22134 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.elasticsearch:elasticsearch (Maven): affected from 7.6.0; fixed in 7.11.0
- org.elasticsearch:elasticsearch (Maven): affected from 7.6.0; fixed in 7.11.0
- elasticsearch (Bitnami): affected from 7.6.0; fixed in 7.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-22134/ (Markdown: https://insights.sbomify.com/CVE-2021-22134/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-22134
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-22134
- OSV: https://osv.dev/vulnerability/CVE-2021-22134

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-22134/
Summaries are generated and may contain mistakes; the official description above is the record.
